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This document identifies changes that have been made to VisionVPM in version 338. 

Release Date 

The release date is 18 December 2008. 

Intended Users 

All of your staff must read this document.  
Please familiarize yourself with the changes that have been made, as they will affect your work 
practices. 

Getting Help 

For queries regarding these changes, or for any assistance in getting the most from VisionVPM, 
please contact your local Provet IT support team.  

 New Zealand Australia  

Phone 0800 847 876 1800 150 264 
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General changes to VisionVPM 

This section describes general changes that have been made to VisionVPM. 

The following windows can now be maximised and resized.  

�  Client Details 

�  Animal Details 

�  Stock Details 

�  Budget. 

This allows you to view more information in each of the windows at one time. 
 

Changes to the Clients Module 

This section describes the changes that have been made to the Clients Module. 
 

Size increase of Company Name and Last Name fields 

Go to: Clients menu > Client Details > find client. 

The size of the Lastname and Company fields on the Client Details window has been increased 
to 50 characters. 

Previously, you could only enter up to 30 characters in these fields.  Users have requested room 
for more characters. 

 
 

Ability to multi-select breeds and species in Marke ting Schedule 

Go to: Clients menu > Marketing Schedule > Insert > Animal tab. 

Having the ability to multi-select breeds means that you can find, for example, cats and dogs that 
match the criteria in a single search and consolidate these so that your clients will receive a single 
letter. 
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A Breed check box and a Species check box have been added to the Animal tab of the 
Marketing Schedule. When selected, this will allow you to select more than one breed and more 
than one species for a marketing search. 

 

For example, if you wanted to send a letter to all cats, dogs, horses and sheep you can now select 
your species code for cats, dogs, horses and sheep in the same search.  

To multi-select lines in a list, hold down the CTRL key and click the lines you wish to include in 
the search, as displayed below: 

 

Previously, you could only select one breed and one species for a marketing search.  
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The example below displays selecting a species DOG in the previous version: 

 
 

Email address verification 

Go to: Clients menu > Client Details > find client. 

VisionVPM will now display an error message when you have entered an invalid email address 
on the Client Details window.  This process will help minimise the number of incorrect email 
addresses entered into VisionVPM.    

 

VisionVPM will check your email addresses against the following criteria: 

��  No Spaces allowed. 

��  Must contain an @ symbol. 

��  Must be a full stop in the 2nd part of the address after the @ symbol. 

��  Must be a name before the @ symbol. 

��  First character cannot be a full stop. 

��  Last character cannot be a full stop. 

	�  Length of the 2nd part of the address after the @ symbol must be greater than 1. 

If VisionVPM detects any of the above details in the email address, a warning message similar to 
the one below will be displayed. 

 

You will need to click OK and correct the email address. 

There is also a new routine in Maintenance > Database Maintenance > Client Maintenance > 
Validate Email Addresses which will detect all invalid email addresses in your database and 
you then have the option of printing a list of these addresses. You should then go through the list 
and correct each client's invalid email address in VisionVPM. 
 



!!�
'�

�

Change to Client Inactivity routine 

Go to: Clients menu > Marketing Schedule > Extra Searches > Client Inactivity . 

A change has been made to this routine to not display any clients who have credit notes or 
reversals in their activity for the selected period. 

Previously, VisionVPM would include on the results list those clients who had reversed or 
negative invoices. 
 

Cancelling a client invoice 

Go to: Clients menu > Animal Details > find animal > Record > Drugs tab > Invoice. 

The following message has been added to VisionVPM and will be displayed if you cancel out of 
a client invoice which was generated from a clinical record. 

 

Click Yes to continue to create the invoice. 

If you click No, you can create the invoice in the future by opening the clinical record and then 
clicking Invoice from the Drugs tab. 
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New sorting on Reminder Schedule 

Go to: Clients menu > Reminder Schedule > select reminder code > enter dates > Run. 

Now, VisionVPM sorts the clients on the Reminder List window in company name and last name 
order. For example, if a client has a Lastname of Smith and a Company name of Jones, they will 
be displayed under J. 

 

If there is no company name, clients will be ordered by Lastname. 

This is to assist you if you send your reminder letters with your accounts, as VisionVPM also 
sorts the invoice/statement run by Company name  and Lastname order. 

Previously, clients were sorted by Lastname only on the Reminder List window, as displayed 
below. 

 
 

Mobile phone number on hospital admission form 

Go to:  

�  Clients menu > Animal Details > find animal > Admit  > enter details > Save > Form. 

�  Clients menu > Client Details > find client > right-click animal > Admit Patient > enter 
details > Save > Form. 

�  Clients menu > Animal Details > find animal > Record > Admit  > enter details > Save > 
Form. 

�  Appointment List > make appointment > right-click animal > Admit  > enter details > Save 
> Form. 
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The client's mobile phone number has been added to the hospital admission form as displayed 
below. 

 
 

Print button on Clinical Record List 

Go to: Clients menu > Clinical Record List > Print . 

A Print button has been added to the Clinical Record List window enabling you to print a list of 
clinical records. 

 

When you click Print the following message will be displayed: 
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If you click Yes, all animals' clinical notes will be displayed, as shown below: 

 

If you click No, only the first line of animals' clinical records will be displayed, as shown below: 

 
 

Changes to the General Ledger Module 

This section describes the changes that have been made to the General Ledger Module. 
 

All general ledger codes importing back into Vision VPM 

Go to: Main menu > General Ledger module > General Ledger menu > Budgets > Excel > 
Save. 

VisionVPM was not importing budget changes made in Excel for any general ledger account 
code that contained a full stop and ended in a zero, for example, 102.50.  This was because Excel 
was treating the code as a number and the end zero was stripped off in Excel. When you 
imported the budget changes back into VisionVPM the code had been changed and wasn't  
recognised. 

Budget export: Old Version 

 

A change has been made in VisionVPM to add a star to the start of all general ledger codes when 
the budget is exported to Excel. This means that Excel will not drop the zero and VisionVPM 
will be able to import all budget changes for all general ledger codes. 
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Budget export: New Version 

 
 

New Subtotal Headers option in Monthly Profit & Los s Report 

Go to: General Ledger module > Reports > Monthly Profit and Loss. 

There is a new Subtotal Header Accounts Only check box on the Date Selection window. 

 

When selected VisionVPM will display only the Header accounts on the report. 

Previously, VisionVPM displayed all accounts on the Profit and Loss Report. 
 

Additions to the Budget window 

Go to: General Leger menu > Budgets. 

The following changes have been made to the Budget window: 

��  The Account column has been increased in width to display the whole account name. 

��  There is a new Type column to display the type of account, for example, Sales. 

��  A vertical scroll bar has been added. 

��  The Budget window is able to be maximised and resized so you can view more information. 

��  All the columns will now sort. 
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An example of the new window is below, highlighting the new Type column and the vertical 
scroll bar. 

 
 

Changes to the Stock Module 

This section describes the changes that have been made to the Stock Module. 
 

Consumables 

Go to: 

�  Stock menu > Stock Details > find stock item. 

�  Stock menu > Stock Details > Insert. 

There has been a overhaul of how VisionVPM handles consumables in this update.  

Previously, a consumable was identified in VisionVPM by leaving the pack cost blank. This was 
an effective method of ensuring the items were not included in stock valuations and inventory 
reports. However, with the introduction of online ordering and the ability of supplier invoices to 
be downloaded electronically,  the cost price is now automatically updated for each item of stock. 
The following changes will help you manage this process and stay in control of your pricing.  

The following are the major changes: 

�  There is a new Consumable check box on the Stock Details window. Other options have 
been relocated on the Stock Details window as shown below. 
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Previous Version New Version 

  

If the Consumable check box is selected: 

�  The stock item will not be included in the Stock Valuation report. 

�  The stock item will not be included in cost of sales calculations. 

�  The stock item when purchased through a supplier invoice will go straight to a purchase or 
expense account, not the stock control account. 

�  The stock item will be listed on stock takes but will not generate a value to the Stock Control 
account when adjusted. 

�  The stock item will not be included in the Stock Levels reports. 

�  The stock item will not be listed on the Stock Variance report. 

Guidelines for consumables (or turn it off) are as follows: 

��  If the product currently has no pack cost and is marked as a consumable then VisionVPM 
will now allow you to add a Pack Cost and still retain this product as a consumable. 

��  If the product has a cost and a stock on hand quantity and you click Consumable, then 
VisionVPM will display a message to run an adjust to zero the balances first. This will make 
sure there is not an unrecorded stock valuation change by suddenly changing the stock item to 
a consumable. 

��  If you are changing from a consumable to a non-consumable and the stock item has a cost 
then you will have to zero the stock on hand quantity first using the Adjust button.  
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Automatic Reordering 

If you wish to use the Stock Reorder function in VisionVPM, please be aware that your 
consumable stock items require a Pack Cost. Please refer to the Mark Stock items as 
consumables section below for more information. 

Consumables List 

A list of consumables can be displayed from Stock module > Reports > Stock List > 
Consumables. 

 
 

Converting Consumables 

Go to: Maintenance menu > Database Maintenance > Stock Maintenance > Mark Stock 
items as consumables. 

If you wish to mark your stock items as consumables simultaneously, there is a new routine in 
Maintenance to do this. 

Please be aware of what will happen if you decide to mark current stock products as 
consumables: 

There are 3 steps to this process as described below: 

��  Creating a new analysis group. 

��  Applying a group of stock items to an analysis group. 

��  Running the Mark Stock items as consumables procedure. 
 

Creating a new analysis group 

��  Go to: Stock menu > Analysis Groups 
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��  Click Insert to add a new analysis group. 

 

��  Click Save. 

A list of analysis groups can be printed from the Analysis Group List window. 
 

Applying a group of stock items to an analysis grou p 

The most effective way to apply an analysis group to your stock items is through the Stock List 

The following example illustrates the steps involved in applying an analysis group of Advantage 
to Advantage brand stock items. 

Go to: Stock menu > Reports > Stock List  

If you have never assigned an analysis group to any of your stock items before, then it is best to 
simply list all of your stock using All Active Stock Records with no restrictions on the report. 
Otherwise, you can select by Sales Group. 

��  Highlight the relevant values by using a combination of [SHIFT] + [Down Arrow]  

��  Click the Add Analysis Group button 

��  From the list of Analysis Groups available, select the one that will group your stock items 
together. 
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Example 1: Applying Analysis Group to Advantage Products 
 

Running the Mark Stock items as consumables procedu re 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Stock Maintenance > Mark Stock items as consumables. 

This routine will mark the nominated stock records in an analysis group as consumable products. 

It will automatically create a stock adjustment removing the stock onhand amount from the stock 
record.  

�  If the stock on hand is a positive amount, the stock adjustment journal will decrease your 
stock control account by the value of the stock on hand and increase your Cost of Sales 
account by the same amount.  

�  If the stock on hand is a negative amount, the stock adjustment journal will increase your 
stock control account by the value of the stock on hand and decrease your Cost of Sales 
account by the same amount.  

NOTE: Depending on the size of the stock adjustment, this may cause an increase or decrease 
in your Cost of Sales in the month that you turn stock products into consumables. Therefore, 
this may then result in a higher or lower profit figure for the month. 

If you wish to use your consumables for automatic reordering you will need to stocktake your 
consumables in order to enter the correct stock onhand amounts. 
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You can choose to attach a particular purchase or expense general ledger account to each stock 
item. 

You can also choose to allow VisionVPM to: 

�  calculate the Pack Cost from the last supplier invoice. 

�  apply $1.00 to the Pack Cost, if there are no previous supplier invoices on the stock record. 

The following message will be displayed when the run the procedure: 

 

��  Click Yes to the above message and the following window will be displayed: 

 

��  Click the Selected Analysis Group arrow to select the Analysis Group which contains the 
stock records that you wish to mark as consumables. 

��  Optional items:  

1. Click the Change the purchase group to arrow and double-click to attach a purchase or 
an expense general ledger account. 

2. Select the Calculate the cost from the purchase activity for items without a cost check 
box. 

3. Select the Calculate the cost as $1 if there is no purchase activity  check box. 

NOTE: If you choose to leave the last two fields blank, the Pack Cost will remain as it was 
prior to running this procedure. 

��  Click OK. 

VisionVPM will: 

�  run through every stock item in the selected analysis group, 

�  mark them as consumables,  
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�  remove any stock on hand,   

�  apply any of the optional items you have selected.  

You can display a list of your consumable stock records by going to Main menu > Stock module 
> Reports menu > Stock List > select Consumable > OK. 
 

Consumables check box on Stock List window 

Go to: Stock menu > Stock Details. 

A Consumables check box has been added to the Stock List window as displayed below.  

This will enable you to distinguish more easily which of your stock items have been marked as 
Consumable. 

Us the scroll bar at the bottom of the window to scroll right to locate the Consumable column. 

 
 

Formulations check box on Stock List window 

Go to: Stock menu > Stock Details. 

A Formulation check box has been added to the Stock List window as displayed below.  

This will enable you to distinguish more easily which of your stock items are formulations. 
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Stock Transfers 

Go to: Stock menu > Stock Transfers. 

VisionVPM has changed the way it processes stock transfers. The quantity transferred was 
previously being stored in the number of packs transferred. When part of a pack was transferred 
there was the possibility for rounding discrepancies. VisionVPM now stores the transfers as the 
number of units transferred. 

Previously, you entered the stock transfer as number of packs as displayed below: 
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Now, you will enter the quantity to be transferred in number of units as displayed below. 
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Date Range on Price Update 

Go to: Stock menu > eSend Options > Provet > Update Prices. 

A Priced Update Date Selection window has been added to this procedure. This enables you to 
enter a date range to limit the stock that is displayed to only those stock items that have been 
purchased within the selected date range. 

The following window will be displayed: 

 

Enter the date range and click OK. VisionVPM will then only display those stock items that have 
been purchased within the date range. 

If you wish to view all stock items, leave the date range blank and click Ok. 
 

Products on Price Update 

Go to: Stock menu > eSend Options > Provet > Update Prices. 

Now, only stock products with a different Provet cost price will be displayed. 

Previously, all stock products were displayed.  
 

Changes to the Payroll Module 

This section describes the changes that have been made to the Payroll Module. 

Note: The Payroll Module is only available in New Zealand 
 

Sick Pay 

Go to: Payroll menu > Employee Records > select employee > Sick. 

There has been a overhaul of how Sick Pay is calculated in VisionVPM. Following are the major 
changes: 

�  VisionVPM will now record the Next Entitlement Date as 6 months after the employee's 
start date. 

�  Where no amount has been entered, the Max Leave (maximum sick leave that can be 
accrued) in VisionVPM will default to 160 hours (20 days).  If you change the Entitlement 
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the maximum sick leave that can be accrued will be Entitlement hrs x 4.  Any amount in the 
Maximum Allowed field in the previous Sick Record window will be carried through to the 
Max Leave field in the new Sick Record window.  

�  According to The Holidays Act 2003, an employee is not entitled to sick pay before they 
have been employed for 6 months.  If sick leave is paid in the employee's first 6 months of 
employment VisionVPM will generate a negative balance for sick leave.  This sick leave will 
be deducted from the first entitlement when it becomes available after the employee has 
worked for six months. 

The Sick Record window in the previous version: 

 

The Sick Record window in new version: 

 

Field Definitions  

Entitlement  

�  Number of hours of sick leave allowed. 

�  Number of months the entitlement is for. 

For example, 40 hours every 12 months. 
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Max Leave 

�  Max Leave is the maximum amount of sick leave the employee can accrue. 

�  According to The Holidays Act 2003,  the minimum cap for accrued sick leave is 20 days in 
the equivalent number of hours.  VisionVPM applies 160 hours or Entitlement hrs x 4 where  
Entitlement hrs has been changed. 

�  For all new employees Max Leave will default to 160 hours.  This can be edited.    

�  When a pay is processed after the Next Entitlement Date VisionVPM will recalculate the 
accrued leave and compare it to the Max Leave amount.  Where accrued leave exceeds the  
Max Leave amount, the Max Leave amount will be displayed in the Accrued Leave field 
for the new entitlement period.  Where the accrued leave amount is less than the Max Leave 
amount, the accrued leave amount will be displayed. 

Next Entitlement Date 

�  For new employees: the first sick leave entitlement date is 6 months after the employee's start 
date.  

�  For existing employees the Next Entitlement date is the start date + 6 months or the 
anniversary of the start date + 6 months. For example, if an employee commenced on 
01/02/06, their Next Entitlement Date will be 01/08/09.  

Opening Balance (Pre-VisionVPM) 

�  The Opening Balance is the number of hours of sick leave that an employee has accrued, 
prior to using the VisionVPM Payroll module. 

�  The Opening Balance for new employees will be set to zero. 

�  When there is a rollover, after passing the Next Entitlement Date, the Opening Balance for 
existing employees will be set to zero and incorporated in the Accrued Leave amount. 

Accrued Leave 

�  The Accrued Leave is the amount of sick leave (in hours) that an employee has accrued 
since the last entitlement date. 

�  On running this update, VisionVPM will: 

1. Automatically transfer the previous Currently Available  amount into the new Accrued 
Leave field. You can check to see if this is correct by printing the Leave Analysis report 
from their start date.  The Leave Analysis report can be printed by going to Payroll menu 
> Employee Records > select employee > Leave Analysis > enter date range > select 
Select Leave. 

2. Automatically transfer any amount in the previous Maximum Allowed to the new Max 
Leave field. 

�  On rollover, after passing the Next Entitlement Date, Accrued Leave will be updated as 
Entitlement + Balance Available prior to rollover.  The Accrued Leave cannot exceed the 
Max Leave. 

Hours Taken 

�  Number of hours of sick leave taken by an employee since the last Entitlement Date. 

�  This amount will be set to zero on passing the employee's Next Entitlement Date. 



!!�
1��

�

Balance Available 

�  The Balance Available is calculated as the Opening Balance amount + Accrued Leave 
amount - Hours Taken amount. 

New Employees 

For each new employee, when you click the Sick button from the Employee Details window, 
VisionVPM will display the following message. 

 

When you click Yes, VisionVPM will automatically enter the following: 

��  Entitlement as 40 hours and number of months as 12. 

��  Max Leave as 160 hours. 

��  Next Entitlement Date as 6 months on from the employee's Start Date. 

If you have not entered the employee's Start Date, VisionVPM will display the following 
message:  

 

You should then click OK and enter: 

��  the Entitlement hrs and months, 

��  the maximum leave that can be accrued, 

��  the Next Entitlement Date. This should be 6 months after the employee commenced. 

Using the Payroll module for the first time 

If you start to use the Payroll module for the first time for existing employees, you will have to 
enter: 

��  an Opening Balance for sick leave for each employee.  

��  The Opening Balance will be the number of hours of sick leave that each employee is 
entitled to until their Next Entitlement Date.  

��  You should also enter an amount into the Max Level field.  Where no amount is entered, the 
default amount will be 160 hours or 4 x Entitlement hrs.  
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Processing a Pay Run 

When you process a pay run, VisionVPM will: 

��  Increase Hours Taken by number of hours of sick leave taken by the employee in the pay 
period you are processing. 

��  Calculate Balance Available based on the Opening Balance + Accrued Leave - Hours 
Taken. 

If the current date passes the Next Entitlement Date VisionVPM will: 

��  Roll over Next Entitlement Date. For example, if the Next Entitlement Date is 01/12/08 
and you process a Pay Run on 02/12/08, VisionVPM will update the Next Entitlement Date 
to be 01/12/09. 

��  Zero the Opening Balance. 

��  Zero the Hours Taken. 

��  Recalculate the accrued leave as Entitlement hrs + Balance Available prior to rollover. 

��  Display the new Accrued Leave amount, unless it exceeds the Max Leave amount, in which 
case the Max leave amount will be displayed as the new Accrued Leave. 

Rolling Over 

A rollover occurs when: 

�  The employee has been employed for a period of more than 6 months. 

�  The employee's Next Entitlement Date is surpassed by the current date. For example, when 
the employee has been employed for 18 months. 

When an employee reaches their first sick leave entitlement date (they have been employed for 6 
months) VisionVPM will, on processing the next pay run: 

��  Calculate the Accrued Leave as the total of Entitlement hrs + Opening Balance - Hours 
taken. 

��  Zero the Opening Balance. 

��  Zero Hours Taken. 

��  Display the Next Entitlement Date as 1 year on. 

When an employee's Next Entitlement Date is reached, VisionVPM will, on processing the next 
pay run: 

��  Zero the Hours Taken. 

��  Recalculate the accrued leave as Entitlement hrs + Balance Available prior to rollover. 

��  Display the new Accrued Leave amount, unless it exceeds the Max Leave amount, in which 
case the Max leave amount will be displayed as the new Accrued Leave. 
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Salary Sacrifice 

Go to: Payroll menu > Employee Details > select employee > KiwiSaver. 

A new Salary Sacrifice check box has been added to the KiwiSaver window. This allows the 
employee to sacrifice a percentage of their gross salary to be part or all of the employer's 
KiwiSaver contribution for the employee.  Check the Inland Revenue website www.ird.govt for 
details on when and how Salary Sacrifice can be used. 

 

The total employee's salary sacrifice amount will be displayed at the bottom of the KiwiSaver 
Details window as shown above. 

As per normal KiwiSaver rules: 

�  the employee contributes either 4% or 8%, 

�  the employer can add a percentage contribution on top of this, and; 

�  if the employers contribution is part of the 4 or 8% then the total employer contribution 
(salary sacrifice + employer contribution) must be at least 2%. Otherwise as the current 
legislation stands, the employer contribution will be 1%. 

When an employee salary sacrifice is in place, this amount is no longer included in the 
employee's gross pay for tax purposes.  VisionVPM will recalculate the employee's gross pay for 
Pay Run calculations. 
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Pay Run 

Go to: Payroll menu > Pay Run. 

When you process a pay run, on the Employee Pay List window, VisionVPM will display the 
employee's Gross amount as the Gross amount less the salary sacrifice amount. 

 

If you double-click the transaction, the following window will be displayed, with the salary 
sacrifice calculation, as highlighted. 
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The KiwiSaver Salary Sacrifice amounts will also be shown on the employee's pay slip in the 
Pay Totals and the Year to Date Totals, as shown below: 

 

EMS File 

Go to: Payroll module > Reports menu > EMS file  

and 

Payroll module > Reports menu > Employer Pay Schedule. 

The employee's KiwiSaver sacrifice amount will be included in the employer's contribution in the 
EMS file and also included in the employer’s contribution in the Employer Pay Schedule report. 

Leave totals available after pay run update 

Go to: Payroll module > Pay Run > Reports > Pay Slips. 

Due to the payroll changes in VisionVPM, all leave totals (Holiday, Sick, Time in Lieu) will only 
be displayed on the pay slips after updating the pay run. 

Previously, Sick Leave and Time in Lieu totals were displayed on the pay slips prior to updating 
the pay run. 
 

Changes to the Maintenance Module 

This section describes the changes that have been made to the Maintenance Module. 
 

Email address verification routine 

Go to: Maintenance menu > Database Maintenance > Client Maintenance > Validate Email 
Addresses. 

There is a new routine in VisionVPM which will check and print any invalid email addresses in 
your database. VisionVPM will check your email addresses against the following criteria: 

��  No Spaces allowed. 
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��  Must contain an @ symbol. 

��  Must be a full stop in the 2nd part of the address after the @ symbol. 

��  Must be a name before the @ symbol. 

��  First character cannot be a full stop. 

��  Last character cannot be a full stop. 

	�  Length of the 2nd part of the address after the @ symbol must be greater than 1. 

An example of the report is below. 

 

You should then change any incorrect email address from the Client Details window. 
 

Stock Transfer check 

Go to: Maintenance menu > Database Maintenance > Stock Maintenance > Dept / Overall  
Stock Differences. 

The following message will be displayed when you have asked VisionVPM to print a report of 
stock on hand differences between your department and overall figures: 

 

When you click Yes to this message, VisionVPM will search and remove any problem-causing 
stock transfers.  
 

Optional hospitalised invoice 

Go to: Maintenance menu > System Defaults > Client tab. 
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A new check box has been added to the Patient Details area which will enable you to not use the 
Hospitalised invoice feature. 

 

If you select the Disable to Hospitalised Invoice check box, when you add stock items through 
the Drugs tab and then click Invoice, the following message will be displayed. 

 

When you click Yes to the message, VisionVPM will add your new stock items to the invoice 
previously created. 
 

Loyalty Balance access 

Go to: Maintenance menu > Users Access. 

An Adjust Loyalty Balance check box has been added to the User Access window. 
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When selected, this will enable this user to change the stock loyalty balances for clients. These 
are changed by going to the Clients menu, pointing to the More Commands menu and then 
selecting Change Loyalty Balances. 

Previously, all users were able to change client loyalty balances. 
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Resolved Issues 

The following issues have been resolved in this build: 

Client Module: 

�  Stock record allowed in editing line when processing payments. 

�  Current member shares not displayed. 

�  Scroll Bar added to Selected Group. 

�  Aged amount incorrect on Aged Debtors report. 

�  Animal Details window incorrectly displayed. 

�  Vet names incorrectly displayed. 

�  Incorrect client write off date. 

�  Incorrect write off amount displayed. 

�  Mileage incorrectly displayed on clinical record. 

�  Incorrect details window displayed. 

�  Incorrect discount displayed. 

General Ledger Module: 

�  Date range changed in Financial Reports. 

Stock Module: 

�  Sales activity incorrect on nested formulations. 

�  Stock items not displayed on Stock Reorder window. 

�  Inactive stock records in Stock Reorder Levels. 

Maintenance Module: 

�  City and Postcode not updating. 

Appointment List: 

�  Blocked notes disappearing. 

�  Incorrect Notified Date on Daily Reminders. 

�  Cursor moving in Appointment List. 

�  New message when double-booking. 

Clients Module 

Stock record allowed in editing line when processin g payments 

Go to: Clients menu > Client Details > find client > Invoice > enter invoice details > Payment. 

In the previous version, VisionVPM allowed you to process a payment even if you had an 
unprocessed stock item in the editing line. 
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Now, VisionVPM will display the following message if you had left a stock item in the editing 
line and clicked the Payment button. 

 

You must click OK and finish processing the invoice. 
 

Current member shares not displayed 

Go to: Clients menu > Client Details > select syndicate client > Syndicate > Print > enter date 
range > Close first report. 

VisionVPM did not print all syndicate members share breakdown on the Syndicate Analysis 
report, if the number of syndicate members was greater than 10. An example of the report in the 
previous version of VisionVPM is below: 

 

Now, VisionVPM will print all syndicate members share breakdown regardless of how many 
syndicate members there are. An example of the changed report is displayed below: 
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Scroll Bar added to Selected Group 

Go to: Clients menu > Animal Details > find animal > History tab. 

A scroll bar has been added to the Selected Group drop-down list. 

 

Previously, there was no scroll bar on the drop-down list, therefore, you could not select an item 
that was at the bottom of the list. 
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Aged amount incorrect on Aged Debtors report 

Go to: Clients menu > Reports > Aged Debtors.  

In the previous version, VisionVPM displayed the client's ageing incorrectly in the Aged Debtors 
report. 

This only occurred when you had: 

��  Created a client invoice. 

��  Reversed the invoice. 

OR 

��  Created a negative invoice. 

��  Added further charging to the invoice so that the total was a positive amount. 

Now, VisionVPM is displaying the correct ageing for all  clients on the Aged Debtors report. 
 

Animal Details window incorrectly displayed 

Go to: Clients menu > Animal Details > find animal > Appt > Save > right-click > Animal . 

Previously, when you had made an appointment for an animal and then wanted to make an 
appointment for another animal, if you right-clicked in the Appointment List and selected 
Animal , VisionVPM would display the Animal Details window of the previous animal. 
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Now, VisionVPM will display the Animal List window, ready for you to find the next animal to 
make the appointment. 
 

Vet names incorrectly displayed 

Go to: 

�  Client menu > Animal Details > find animal > Report > Vaccination Certificate > Print 
Report > select report destination > OK. 

�  Client menu > Reminder Schedule > select reminder code > enter date range > Run > 
Adhocs > Vaccination Certificate > Print  > select report destination > OK. 

Previously, VisionVPM did not allow you to scroll through the entire Vet Name list in the Vet 
Name Selection window, as displayed below: 

 

Now, VisionVPM allows you to scroll through the entire list of vet names, as displayed below: 

 
 

Incorrect client write off date 

Go to: Clients menu > Client Details > select client > Write Off . 

Previously, if a client write off was entered and the date was changed to an earlier date, 
VisionVPM reverted to today's date on saving. The incorrect date was displayed in the Notes tab 
of the Client Details window. 

VisionVPM now displays the correct date for client write offs. 
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Incorrect write off amount displayed 

Go to: Clients menu > Marketing Schedule > Insert > select search criteria > Run > Merge > 
Word. 

When merging to Word, and using the  merge field, VisionVPM displayed only the last write off 
amount for a client. This was incorrect if the client had multiple write offs. 

Now, VisionVPM will display the total write off amount for each client in the merged document. 

Mileage incorrectly displayed on clinical record 

Go to: Clients menu > Animal Details > select animal > Record > Drugs tab. 

VisionVPM displayed a quantity of 1 when you entered a stock record which was marked as a 
Mileage type, regardless of what amount had been entered as the Charging Distance multiplier 
in the Settings tab of the Client Details window. 

Now when you enter a mileage-type stock record, VisionVPM will display either: 

�  the Charging Distance multiplier for the client, or 

if you are  invoicing a horse, which has a location code and the location code has a Distance 
multiplier attached: 

�  The Distance multiplier for the Location code. 

The Distance multiplier for the equine record takes priority over the client’s Charging Distance 
amount. 

Incorrect details window displayed 

Go to: Clients menu > Clinical Record List. 

Previously, if you selected a line in the list and clicked Animal , VisionVPM displayed the Client 
Details window and if you clicked Client, VisionVPM displayed the Animal Details window. 

Now, VisionVPM displays the correct corresponding window when you click either the Client or 
Animal  buttons. 

Incorrect discount displayed 

Go to: Clients menu > Client Details > select client > Invoice. 

In the previous version, VisionVPM displayed the incorrect stock discount amount on a client 
invoice in the following circumstances: 

�  You invoiced a stock item which was included in a cost plus percentage discount group. 

�  You had selected to display a single discount line per invoice in Maintenance > System 
Defaults > Stock tab. 

�  The invoiced stock item included a dispense fee. 

�  You removed the dispense fee from the invoice. 

Now, VisionVPM will correctly display the discount amount. 
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General Ledger Module 

Date range changed in Financial Reports 

Go to: General Ledger menu > Financial Reports. 

Previously, VisionVPM would allow you to enter a data range greater than a year.  

This was causing incorrect data to be displayed if you entered a Year Begins date outside of the 
date range that you entered; example below: 

 

Now, VisionVPM will display the following message if you have entered a date range greater 
than a year: 

 

You will have to click OK and enter a date range within a year. 
 

Stock Module 

Sales activity incorrect on nested formulations 

Go to: Stock menu > Stock Details > select stock record > Formulations. 

Previously, VisionVPM was not recording the sales activity for stock items when the stock items 
were part of a nested formulation. 

Now, sales activity is being recorded for all stock items within formulations. You can nest up to 
3 tiers of formulations. For example, you can have a formulation within a formulation within 
another formulation. 
 

Stock items not displayed on Stock Reorder window 

Go to: Stock menu > Stock Ordering > Stock Reorder > select supplier > select department. 

In the previous version, VisionVPM did not display stock items on the Reorder List window.  

This only occurred when: 
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��  You were using departments. 

��  You had selected to order by a departments. 

��  There was no previous activity (purchases or sales) on the stock item for the department. 

��  You had set up Standard Reorder Levels for the department. 

Now, all stock items will be displayed on the Stock List regardless of whether there is previous 
activity for a department or not. 
 

Inactive stock records in Stock Reorder Levels 

Go to: Stock menu > Stock Ordering > Set Reorder Levels. 

In the previous version, VisionVPM included inactive stock records in the Stock Reorder Levels 
window.  

This has been corrected and in the latest update, inactive stock records are excluded from the list. 
 

Maintenance Module 

City and Post Code not updating 

Go to: Maintenance menu > Codes and Descriptions > Client Address Locations. 

In the previous version, VisionVPM did not update the City or Postcode fields of existing clients 
when the Suburb was changed. 

Now, if you change any Suburb details, VisionVPM will display a message similar to the one 
below. 

 

Click Yes, and VisionVPM will automatically change all existing client's City and Postcode 
details accordingly. 
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Appointment List 

Blocked notes disappearing 

Go to: Main menu > Appointment List . 

Previously, if Vision refreshed the Appointment List window this would clear what you had 
typed into a blocked timeslot,  This only occurred if you were using the tab version of the 
Appointment Book. 

Now, VisionVPM retains what you have entered into a blocked timeslot. 
 

Incorrect Notified Date on Daily Reminders 

Go to: Main menu > Appointment List >  > Daily Reminders > enter date range > select 
reminder > Notified. 

Previously, when you had entered a Notified Date on a selected reminder, VisionVPM was 
automatically entering the date you entered on all reminders on the list. See example below. 

 

Now, VisionVPM will only change the Notified Date on the reminder that you have selected. 



!!�
�,�

�

 

 
 

Cursor moving in Appointment List 

Go to: Main menu > Appointment List . 

In the previous version, VisionVPM would move the cursor to the first timeslot of the day when 
the following had occurred: 

��  Entered an appointment for a day other than the current day. 

��  Clicked Update. 

Now, the cursor will remain on the appointment that you have entered until you move the cursor. 
This will enable you to check the appointment you have made without the window moving. 
 

New message when double-booking 

Go to:  

�  Main menu > Appointment List  > select timeslot > Client. 

�  Main menu > Appointment List  > select timeslot > Animal . 

Now, when you attempt to create an appointment at the same time as someone else for the same 
date, time and appointment book VisionVPM will display the following message. 

 

To create an appointment for the same timeslot click Yes, otherwise click No to change the date, 
time or appointment book. 

Previously, VisionVPM allowed you to make double-appointments without warning that 
someone else was attempting to make an appointment for the same timeslot.
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