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Version 1.0 

 
VisionVPM user documentation is continually being developed. For the most up-to-date 

documentation please visit the VisionVPM website at  
www.visionvpm.com
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Many settings and options for VisionVPM are set up through the Maintenance module. These 
settings are offered so you can customise VisionVPM to meet your business requirements and to 
make your data use and reporting as efficient as possible. 

Codes and descriptions for various fields are also set up in the Maintenance module.  

The Maintenance module also offers many other utilities including ways to group data and check 
transactions. 
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Setup 

The setup section covers the settings you may wish to review when VisionVPM program is 
initially installed. 

Most of these settings can be changed at a later time. If you find VisionVPM is not performing as 
you would like, check the available settings or contact the Provet IT Service Desk for assistance. 
There may already be options available to get VisionVPM working the way you want. 

 
 

Company Information 

This window is where clinic and GST details are entered so they can be utilised in other areas of 
VisionVPM. 

Go to: Main menu > Maintenance module > Maintenance menu > Company Information 

 

Settings 

The following details will appear on invoices and invoice/statements when the appropriate type 
of invoice or invoice/statement is selected.  
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�  Company Name 

�  Address 

�  Phone Number 
�  Email address. 

Year Begins is the first day of your financial year. For example, 1 April 2007. It is reset when an 
End of Year Rollover is performed. This date should not be changed without consultation with 
Provet IT Support. A password is required to change the Year Begins date.  

GST Number is required for NZ clinics. 

GST Basis: select the method by which you pay GST: 

�  Invoice (Accrual). 

�  Payments (Cash). 

GST Rate: Enter the current GST Rate. At time of writing this is 12.5% for New Zealand and 
10% for Australia. 

Version: This field is automatically populated when installing VisionVPM and it is the version 
number of the program. When you update with a new release, this field is updated automatically. 
This entry should not be changed unless advised by VisionVPM staff.  

Header Info: An area where you can enter your company's motto or slogan. If you do not use 
letterhead, the Header Info will print between the Company Name and Phone Number on 
invoices. 

ABN Number: Australian Business Number. 

ACN Number: Australian Company Number. 

Type: The type of installation - for New Zealand or Australia. This gives access to appropriate 
modules and invoice or invoice/statement formats for that country. 

�  0 = New Zealand 

�  1 – Australia. 

Click Save to save the settings and close the window. 
 

Account Defaults 

The Account Defaults window displays the default General Ledger account codes used for 
control accounts and various other default settings. 

Any required General Ledger accounts can be set up through the General Ledger Module. 
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To set up a General Ledger Account 

��  Go to: Main menu > General Ledger Module > General Ledger menu > Chart of 
Accounts. 

 

��  Click Insert. 

��  Enter the Account Code and a name or description for the account. 

��  If the account is to be subtotalled to another account, use the list arrow to select that account. 

��  Enter a Page No if required. 

��  Select the account type by clicking on the button for that option. 

	�  If GST does not apply to the account, select Zero Rated for GST? 


�  If the account is a bank account, select Bank Account. 

The Level box in the lower right hand corner will display the subtotalling level for that account. 
If it has not been subtotalled to another account, the level will be 0. The System ID box displays 
the system generated code for that account. 

A standard set of general ledger chart of accounts is included in the database. You can  change 
these codes in consultation with your accountant and VisionVPM staff.  
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To Enter Account Default Settings 

Go to: Main menu > Maintenance module > Maintenance menu > Account Defaults. 

 

Settings 

The following are the default control accounts that are set up on installation of VisionVPM: 

�  Retained Earnings 

�  Debtor Control 

�  Creditor Control  

�  GST Control 

�  Default Bank 

�  Default Safe 

�  Unders & Overs 

�  Cheq Clear A/c 

�  Account Fees A/c 

�  Eftpos Holding Account 

�  Bad Debt A/c 

�  Cash Sale A/c 

�  Discount Received A/c 
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�  Sales Control 

�  Cost of Sales 

�  Stock on Hand 

�  Default Till  

�  Default Asset A/c 

�  Depreciation A/c 

�  Loss on Asset Sales 

�  Interest A/c 

In addition to the default control accounts you can also set up the following items in this window:  

�  Cheq Clear Fee: The amount to be charged for each cheque above the number of free 
cheques, as described below. 

�  No. of Free Cheqs: The number of cheques the bank will accept before a cheque clearance 
fee is charged. 

�  Account Fee: The amount that will be charged to clients with an outstanding balance at 
month end, for example, $5.00 

�  Min A/c Fees Balance: The minimum outstanding client balance to which account fees will 
be applied. This can be set at 0.00 to generate account fees on all outstanding balances. 

�  Charge A/c Fees @: The account period when account fees will be applied. For example, 1 
month overdue. Use the list menu to select. 

�  Goods Receipt Account: If you are going to use goods receipts in VisionVPM, enter the 
general ledger code for your goods receipt account. 

�  DC Batch Payment Account: An account code must be entered if you wish to batch your 
supplier payments in the bank reconciliation window. 

�  Stock Adjustments:  This account code must be entered before you run the procedure 
Create COS Journals, as part of your end of month processes. 

�  Stock Wastage: This account is used for stock adjustments related to wastage, for example 
when stock has passed its use by date, or the packaging is damaged and it cannot be sold. 
This might include dead fish, or any other form of wastage within the clinic. 

�  Monthly Interest %:  The amount of interest to be charged on client balances at month end. 

�  Min Interest Bal:  The minimum client balance for interest to be generated. This can be set at 
0.00 to generate interest on all outstanding balances. 

�  Charge Interest @: The account period where interest will be generated. For example, 1 
month overdue. Use the list menu to select. 

�  Eftpos Bank Account: If you wish your eftpos payments to be entered into a bank account 
other than your Default Bank a/c, enter the general ledger code for your eftpos bank account 
in this field. 

�  Incentive Discount Account: If you wish to use incentive discounts, enter the code for the 
general ledger account for incentive discounts. 

�  Syndicate Holding A/c:  If you wish to use syndicates, enter the code for the syndicate 
holding account. 

�  Credit Card Holding A/c:  If you wish to pay suppliers using a personal credit card enter the 
general ledger account for the credit card holding account. 



��
�

�

Click Save to save the settings and close the window. 

All required fields must be correctly completed on this window to enable VisionVPM to 
correctly allocate money to the appropriate General Ledger accounts, charge account fees and 
interest, charge dispensing fees and process bankings. 

System Defaults 

The System Defaults window gives a number of options for the way VisionVPM is run. These 
are System settings which will affect every computer connected to the server. 

To set up or change System Default Settings 

Go to: Main menu > Maintenance module > Maintenance menu > System Defaults. 

 

The System Tab 

General System Settings 

��������� ��
����
Use mixed case names on 
selected fields 

Defaults the first letter of each part of the name to a 
capital letter automatically. 

Use VPM with multiple 
clinics through remote 
access 

Select only if using terminal server. 

Use A5 for selected reports Print selected reports on A5 paper rather than A4. 
Use analysis by department Allows selection of analysis by department rather 
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than analysis of the whole entity. 

Make the user field 
compulsory 

Makes it compulsory to enter user codes on 
transaction windows, for example, invoices. 

Use printers added to 
printer setup only 

This means that the user must use a printer that is 
setup in Maintenance. 

Edit mode on main detail windows 

��������� ��
����
Windows to use permanent 
edit mode. 

Data entry windows will be permanently in edit 
mode – no need to click the edit button before 
making changes. 

Windows not in permanent 
edit mode till activated. 

Click Edit to make any changes to existing records 
– client, animal, stock, supplier. 

Other Settings 

��������� ��
����
Main Menu Name Allows you to change the name of the Main menu. 

An ampersand '&' should be inserted in front of the 
name if you use quick keys to access the menu. 

Default department The default department for the system can be 
entered here. 
Note: a default dept loaded in Maintenance > 
Computer defaults will override this setting. 

Clinical record font  Allows you to select a default font for clinical 
record entries.  Choose from 1 - 5. 

Lock clinical records after 
.....days 

Prevents alterations to the clinical records after the 
stipulated time. 

Last statement number Records the last statement number. Enables a start 
number for statements to be selected in a new 
system. 

Dairy export name A unique name given to the clinic by Fonterra for 
an export balances routine (Clients > Reports). 

Path to documents on server The path to where word documents used by 
VisionVPM are stored on the server computer. 
Enables work stations to save documents in a 
common file on the server.  Browse to find 
document location.   

Path to omnis7 folder on 
server (laptop transfer)  

A path used for the laptop transfer process. 

Optional server name (.net 
applications) 

When a .net application requires a server name this 
can be entered here. 

Click Save to save the settings and close the window. 
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Extra Setup Windows 

Buttons at the bottom of the System Default window give access to additional set-up windows: 
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Appointment Options Offers options for the appointment book – refer to 

Appointment section. 
Invoice/Receipt Options For set up of slip printer and messages. 
Setup Drug Labels Offers options for drug labels. 
PACS Setup Offers options for setup of  PACs modality. 
Email Setup Offers options for setup of VPM Mail. 

 
 

Appointment Options 

You can choose which type of appointment list you use, how your appointments are displayed, 
the colours of the various statuses of the appointment list and whether or not you want photos 
displayed on your appointment book.  

These are system settings so they will apply to every computer in the clinic. 

To set up or change Appointment Options 

Go to: Main menu > Maintenance Module > Maintenance menu > System Defaults.  

Click Appointment Options. 
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Settings 

�  Select Use Multi- column Appt book to display a column for each appointment book. If this 
is not selected, the window will display a single appointment book at a time, with tabs for 
access to the other books 

�  Enter the time in seconds in the Update Appointments every box. This is how frequently 
VisionVPM will update the waiting time. 

�  Click the appropriate button to select your preferred Display Option for the client names in 
the appointment time slots. 

�  Select Show appointment book photos to display a photo at the top of each appointment 
book. These are used by some clinics to help clients identify the vet they saw previously. 

�  Select Show appt notes on the clinical record to have the appointment notes transferred to 
the clinical record when opened. 

�  Select Show the animal name in the waiting room to have the animals' names displayed in 
the waiting room after arrival. 

�  Colour options for the stated text or background for each type of time slot can be chosen 
using the Select buttons for the relevant fields.  

�  Clicking the Optional Types arrow will offer a choice of several colour sets for the text and 
background. 

�  The size of the appointment cell can be defined by entering the size (in mm) in the Width 
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and Height boxes.  

�  Any or all of the Appointment Cell Options can be selected. These determine the 
information displayed in the appointment cell. 

Note: Several of the options apply only to the Multi-Column Appointment Book. 

Click Close to close the window and click Save on the System Defaults window to save the 
options. 

Putting in place the appropriate settings for clinic use will increase the efficiency and user-
friendliness of VisionVPM and customise VisionVPM for your clinic's requirements. 
 

Invoice/Receipt Options 

This window is for the setup of slip printer and messages and to determine whether the balance 
due on invoice and receipts will be displayed.  

To setup or change Invoice/Receipt Options 

��  Go to: Main menu > Maintenance Module > Maintenance menu > System Defaults.  

��  Click Invoice/Receipt Options. 

 

��  Settings 

��  For 'New Standard' invoice report formats 

��  If a slip printer is used for printing invoices and receipts, Slip Printer Codes and the amount 
of  Slip Printer LIne Feed can be entered here. 
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��  Select Show balance due on invoice and receipts where required. 

	�  Optional: Enter the text of a message to be included on any invoices with the 'new standard 
format' 


�  For all invoice/receipt report formats 

��  Enter Left Margin  where required. 

���  Select Print a second copy of the invoice and receipt where a second copy of all invoices 
and receipts is required (for hard copy storage). 

���  Click Close to close the window and click Save on the System Defaults window to save the 
options. 

 

Setting up Drug Labels 

Default drug label settings can be applied in this window. The settings you select will depend on 
whether you are using pre-printed labels and what information is pre-printed. 

To setup or change Drug Label defaults 

��  Go to: Main menu > Maintenance Module > Maintenance menu > System Defaults.  

��  Click Setup Drug Labels. 

��   

��  Settings 

��  Select the Warning Message you require buy clicking on the appropriate button.  

��  No warning message 

	�  Animal Treatment Only Keep out of the reach of Children 


�  Keep out of the reach of children. 

��  You can select to Include Company Name On Label.   

���  The name of the Vet whose code is selected on Drug window of the clinical record will be 
included on all labels if Include Vet and Emergency Phone No is selected.  

���  Type in the Emergency Ph number if required. 
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���  Click Close to close the window and click Save on the System Defaults window to save the 
options. 

 

PACS Setup 

PACS are Picture Archiving and Communication Systems and are servers dedicated to the 
storage, retrieval, distribution and presentation of medical images. 

An interface to a PACS system provided by Central Data Networks (CDN) is available through 
VisionVPM. The PACS interface is available through Provet IT for clinics using the CDN PACS 
system.  

To setup VisionVPM for the PACS interface 

Once the interface software has been loaded, VisionVPM must be set up to work with the 
interface and the PACS system. 

��  Go to: Main menu > Maintenance Module > Maintenance menu > System Defaults. 

��  Click PACS Setup. 

��   

��  Enter the information relevant for your system. 

��  Click Update to close the window and click Save on the System Defaults window to save 
the options. 

 

VPM Mail Setup 

The Email settings window allows you to choose between using Microsoft Outlook or VPMMail 
when sending individual emails from the Client Details window as well as providing setup 
options for SMTP Server and reply email addresses.  
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To setup or change email settings 

��  Go to: Main menu > Maintenance Module > Maintenance menu > System Defaults.  

��  Click PACS Setup. 

��   

��  The default option for sending individual emails is still Outlook. Select VPMMail if you 
wish for individual emails to be sent through VPMMail. Merging to email through Marketing 
or Reminder Schedule will always use VPMMail.  

��  When using VPMMail the following options must be set: 

��  SMTP Serveraddress (name or IP): This is the name of the server through which your 
emails are sent. If you use a mail server on your network you would enter the name or IP 
address of that server. Otherwise, if you send emails through an Internet Service Provider 
(ISP) such as Xtra or Telstra Clear you would use their SMTP details. An example for 
accounts with Xtra would be send.xtra.co.nz 

	�  Default reply email address: This is the main email address for your clinic which will be 
sent with each email. This address can be changed to one of the 'extra' reply addresses at the 
time of sending an email. 


�  Extra Reply Addresses:  A list of alternative reply addresses can be entered here. The 
required address can then be selected from a drop down list when sending an email. The 
addresses should be entered on a separate line  with just a carriage return between them. 

��  Click Update to close the window and click Save on the System Defaults window to save 
the options. 
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Client and Patient Settings 

To set up or change Client and Patient Settings 

Go to: Main menu > Maintenance module > Maintenance menu > System Defaults > Client 
tab. 

 

Settings 

Client Details 

��������� ��
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Use the client's last name as 
the default search 

Defaults the client search to the last name field. 
 

Default Search For selection of the type of default search. 
Disable the client first name 
field 

This option is for clinics that do not use the client 
first name field. 

Load the first animal when 
moving to the animal 
window 

When selected, the first animal in the Animal list 
will be loaded when you click the animal button on 
the client window. 
If not selected, a window for inserting a new animal 
will be displayed. 

Hide deceased animals from 
the patient list 

The names of deceased animals will not be 
displayed in the animal section of the client details 
window.  
If not selected they are visible at the bottom of the 
animal window. 
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Patient Details 

��������� ��
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Disallow multiple animals 
being listed on the invoice 

Selecting this will mean that VisionVPM will not 
add multiple animals on an invoice when you are 
moving between different Animal Details windows. 

Disable breeds being added 
from the animal window 

Prevents animal breeds being added from the animal 
details screen as new animals are entered. 

Display animal's weight as 
grams instead of kilograms 

Shows animal weight in grams – useful for clinics 
with many birds or small exotics as patients. 

Disable the external 
photo/file count 

Disables the count on external attachments to speed 
up processing. 

Disable the Hospitalised 
Invoice 

The hospitalised invoice option and its associated 
prompts are not displayed.   

Other Settings 
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Create a diary task of 
downloaded lab results 

When selected,VisionVPM will create a diary task 
when a lab result is downloaded. 

Prompt for the vet's code on 
invoices and clinical records 

When selected, VisionVPM always prompts  for vet 
codes on invoices and clinical records. 

Client Address Settings 

��������� ��
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Client Code Select the type of Client Code generated from the 

Client Details. 
Address Labels Allows a setup to be chosen for address labels. 

Client name display  How VisionVPM will display and print the client's 
name  on labels and correspondence. 

Exactly match above Uses exactly the fields specified.   
If this is not selected, VisionVPM may make some 
smart substitutions when fields are not populated.   

Numeric code starting 
number 

Enables selection of a start number for codes, if 
required. 

Default Suburb Optional - The suburb field of all new client records 
will be populated with a suburb entered here.  It can 
be overtyped in the client records if required. 

Star client list number How many top clients you want identified with 
stars. 

Default City Optional – The entry here will populate the city 
field of all new client records.  It can be overtyped 
in the client records if required. 
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To Set up for a page of Labels 

Click on the Cut Sheet button to display the label configuration window. 

 

The label height and label width are measured from the start of one label to the start of another, 
even if the labels have strips between them. Your settings may need adjustment to fit your label 
page exactly. 

Click Close to close the Label Configuration window and click Save on the System Defaults 
window to save your settings. 
 

Financial Settings 

To set up or change Financial Settings 

Go to: Main menu > Maintenance module > Maintenance menu > System Defaults > 
Financial tab. 
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Settings 

Client Invoicing 

��������� ��
����
Use the generic stock name 
on client invoices 

Where there is a generic stock name listed in the 
Stock Details window, this will be loaded on the 
invoice rather than the product name. 

Don't add stock messages 
into the invoice message 
field 

When this option is selected, stock messages will be 
displayed in the invoice message area at the bottom 
of the invoice, but not in the body of the invoice. If 
not selected, the stock messages appear both in the 
body of the message and at the bottom of the 
invoice. 

Don't write the discount 
amount into the items 
description 

The discount comment will not be included in the 
item description. 

Display invoice item 
amounts without GST 

Invoice line items will be displayed excluding GST. 

Prompt when adding 
products with a dispense fee 

A prompt is displayed when products with an 
attached dispensing fee are inserted on the invoice.  
This gives the opportunity to check and change the 
dispensing fee and view the total price before the 
price is loaded. 

Round stock items to the 
nearest 10c 

Invoice line items will be rounded to the nearest 5 
cents. 

Prompt if a payment is not 
added to an invoice 

Generates a prompt when the invoice is closed or 
printed, but no payment has been made. 

Display the reminder 
window when new 
reminders created 

VisionVPM will display the reminder window on 
saving an invoice which contains stock items with 
reminders attached. 

Prompt for stock letters to 
be printed 

VisionVPM will prompt to print stock letters on 
saving an invoice which contains stock items with 
letters attached. 

Use clinical record date on 
the invoice 

If this option is selected, the default date for the 
invoice will be the clinical record date. If this option 
is not selected the default date is today's date. 

Use equine location field on 
batch invoicing 

Displays the equine location field in the Batch 
Invoicing window.  The location field will print on 
the invoice. 

Client Payments 

��������� ��
����
Default the payment amount 
to equal the total of the 
invoice 

The default payment amount will be equal to the 
total of the invoice, rather than the total owed. 
 

Disable the eftpos 
withdrawn field  

Cash withdrawals associated with Eftpos 
transactions will be disabled. 
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Client Financial 

��������� ��
����
Only view cheques on the 
bank deposit after saving 
the till  

Cheques do not appear in the bank deposit until the 
till balance is saved. 

Allow mid-month dates for 
client statements and aged 
analysis 

Allows statements and some financial reports to be 
run at times other than the end of the month. 

 

Client / Supplier Activity 

��������� ��
����
View client/supplier activity 
items automatically 

Opens the activity windows with View Item 
selected.  (Item field at bottom displayed.) 

 

General Ledger 

��������� ��
����
Use department budgets 
�

Departmental budgets are only available if Analysis 
by Department is selected. 

Check for automatic 
payments on a Bank 
reconciliation 

On opening the Bank Reconciliation VisionVPM 
will prompt to check for automatic deposits and 
payments. 

Click Save to close the window and save your settings. 
 

Stock Settings 

To set up or change Stock Settings 

Go to: Main menu > Maintenance module > Maintenance menu > System Defaults > Stock 
tab. 
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Settings 

Stock Settings 

��������� ��
����
Use the stock's description 
as the default search 

The Search by field will default to stock 
description rather than stock code. 

Default Search Select the type of default search. 

Use Average cost for stock 
valuations.  Calculate the 
average cost from  ...... 

Enables a current date to be selected for stock 
valuation. 

Use a zero stocktake As part of stock taking procedures, you can elect to 
zero the stock on hand quantities before entering 
correct stock figures. 

Hide the onhand quantity 
for non stock / consumable 
items 

Hides the negative onhand quantity for stock items 
which are not purchased, for example, services and 
fees. 

Automatically display the 
stock list when an exact 
product is not found 

A stock list will automatically be displayed if a code 
or a description without an exact match is entered. 

Use a bar code scanner for 
finding products on the code 
field 

Select only if using a bar code scanner. 

Prompt on non-exact bar 
codes 

When this option is selected a prompt will be 
displayed when there are no matching bar codes.   
If this option is not selected, the closest matching 
bar code will be displayed. 

Display the department 
onhand on the stock details 
window 

When this option is selected, the department stock 
on hand amount will be displayed in the Stock 
Details window. 
If not selected, the total stock on hand amount will 
be displayed in the Stock Details window. 

Dispensing fee multiplier Multiplies the amount in this field with the 
dispensing fee in the Stock Details window and 
applies it to the stock item. 

Discount Options 

��������� ��
����
Store the discount against 
each stock item 

Stores the discount against each individual stock 
item instead of allocating to one discount account. 

Add a single discount line 
item per invoice 

Add one discount line per invoice rather than a 
discount line per stock item. 

Discount stock code Enter a stock code for applying discounts. 

Click Save to close the window and save the settings. 
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Computer Defaults 

The Computer Defaults window is where individual workstation settings can be selected. These 
include, for example, default settings for printers, appointment books and receipts. Access to 
Word and Excel is also set up in this window. 

To set up or change Computer Defaults 

Go to: Main menu > Maintenance module > Maintenance menu > Computer Defaults. 

 

To Set up Computer Default Paths 

Most of the paths in the Computer Defaults window can be set using the Browse buttons 
available. 
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Click the Browse button to display a Please locate window. 

 

Click the Drives arrow and then select the correct drive. 

Scroll through the folders on the right. Double-click on the required folder to open and display 
the folders it contains.  

When there are .exe files present in the folder, these will be displayed on the left-hand side of the 
window. Double-click the appropriate .exe file to select. The path will then be displayed in the 
box on the Computer Defaults window. 

Typical paths: 

�	
��
��� �	
��
MS Paint C:\WINDOWS\system32\mspaint.exe 

MS Word C:\program files\Microsoft 
Office\OFFICE11\WINWORD.EXE 

Wordpad C:\Program Files\Windows 
NT\Accessories\wordpad.exe 

MS Excel C:\program files\Microsoft 
Office\OFFICE11\EXCEL.EXE 

Web browser C:\program files\Internet 
Explorer\IEXPLORE.EXE 
 

Letters Ideally these paths should lead to common files on 
the server.   
This way only one file on the server needs to be 
updated, rather than files on every workstation. 

Clinic Docs 

Adhocs 

The file within the Microsoft Office folder may have a different number depending on the 
version of MS Office you are using, that is, it may be OFFICE, OFFICE10, OFFICE11, etc. 

Set up EITHER a path to Word OR a path to Wordpad. If you choose to use Wordpad you must 
check the box: Use Wordpad for client/animal new documents. 



���
�

�

To Set up printers and cashdrawers 

This allows specific printers to be selected for specific purposes for this workstation. It also 
allows a cashdrawer to be fired by appropriate payment transactions: Cash, cheques and Eftpos 
(for the slips). 

The options include: 

�  Slip Printer  – prints on continuous narrow paper. 

�  Cashdrawer – opens for payment transactions. 

�  Cashdrawer printer – a printer attached to the cashdrawer. 

�  Invoice/Receipt Printer – default printer for printing invoices and receipts. 

�  Label printer  – for printing drug labels. 

�  Default screen printer – for printing reports to screen. 

To Set up a Slip Printer   

Setting up a slip printer in VisionVPM is a technical procedure. We recommend consulting your 
local computer hardware support. Technical information is available through the Provet IT 
Service Desk. 

To Set up a Cashdrawer 

In VisionVPM the cash drawer can either be connected directly to the computer or connected to a 
slip printer.  Setting up a cashdrawer is a technical procedure. We recommend consulting your 
local computer hardware support. 

When the cashdrawer is connected to computer directly: 

��  Go to: Main menu > Maintenance module > Maintenance menu > Computer Defaults 

��  Ensure there is a tick in Cashdrawer on this workstation and enter the Port that the 
cashdrawer is connected to. 

Where the cashdrawer needs to fire from multiple machines, set up a printer driver (of any type) 
and assign it to print to the cashdrawer port.  

��  This printer can then be shared so other workstations are able to use it.  

��  Load the name of the printer into Main menu > Maintenance module > Maintenance menu 
> Computer Defaults > Cashdrawer Printer. 

When the cashdrawer is connected to slip printer: 

��  Go to: Main menu > Maintenance module > Maintenance menu > Computer Defaults 

��  Ensure there is no tick in Cashdrawer on this workstation and no entry in the Port field.  

��  Use the facility within the printer driver to fire the cashdrawer, if available. If not use a 
generic/text only driver and enter the codes required by the slip printer to fire the cashdrawer.  

��  Load the printer name into the Cashdrawer Printer box in Computer Defaults. 
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To set up Printers for this workstation 

Setting up printers can be a technical procedure. We recommend consulting your local computer 
hardware support. 

Before doing any printer setup within VisionVPM: 

��  All required printers must first be installed on the PC and configured correctly. 

��  All correct paper/label sizes must be set in Windows > Control Panel > Printers/Faxes 
prior being added to VisionVPM. 

��  Test the printer is working correctly using an application such as Notepad. Do NOT use the 
Windows > Print Test Page functionality. 

Where to set up Printers in VisionVPM: 

First check the version of Omnis on the workstation. Click File > About Omnis 7.3 and check 
the version number. 

�  If the computer is running Omnis 736, printers must be set up in Main menu > Maintenance 
Module > Maintenance Menu > Printer Setup, AS WELL AS Main menu > Maintenance 
Module > Maintenance Menu > Computer Defaults. 

�  If the computer is running Omnis 737, or 738, printers only need to be set up in Main menu > 
Maintenance Module > Maintenance Menu > Computer Defaults. 

To set up a printer in Computer Defaults 

It is important to set up the printers that will be used by the workstation in Computer Defaults. 

��  Go to: Main menu > Maintenance module > Maintenance menu > Computer Defaults 

��  Use the Browse buttons beside the printer boxes to display the list of available printers.  

��  Select the required printer and click on OK to close the window. Click on the Store button to 
store the address and it will appear in the box. 

Setting Other Default Options 

Several default options for the workstation can be set up in Computer Defaults. 

Go to: Main menu > Maintenance module > Maintenance menu > Computer Defaults. 

�  Default Report allows selection of the format for printing invoices. 
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The non-selected report format will only print if you select a printer NOT loaded in Main 
menu > Maintenance module > Maintenance menu > Computer Defaults > 
Invoice/Receipt Printer. 

 
�  Default Vet - When a code is entered, the vet field on any item will be populated with this 

code. This is useful if there is only one vet at the clinic or only one vet using this workstation. 

The Default Vet code can be overtyped if necessary. 

�  If a Default Dept number is entered, this will appear in the department field on any item. This 
should be used when a computer is used within only one department of the clinic. 

The Default Dept Code can be overtyped if necessary. 

 
�  Receipt Printing - The options for printing receipts from the Client Details window are: 

 
�  No Receipt Printed -  No receipts are printed. VisionVPM does not offer to print a 

receipt.  

�  Prompt for Receipt - When a payment is made VisionVPM will prompt to print a 
receipt. 

�  Automatically Print - A receipt is automatically printed for every payment. 

Click Save to save the settings and close the window. 
 

Mobile Laptop Options 

Laptops can be set up as normal work stations where they are used in the clinic all the time and 
linked to the server. 

Mobile laptops are not always linked to the server. Data entered into VisionVPM off site can be 
imported back into VisionVPM on return to the clinic. Mobile Laptops require a Laptop Transfer 
licence and software and a licensed VisionVPM program. 

Please contact the Provet IT Service Desk for full information on the set up of a Mobile Laptop. 
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Mobile Laptop Settings 

Go to: Main menu > Maintenance module > Maintenance menu > Computer Defaults > 
Mobile laptop 

 

Your Key is available with the Laptop transfer licence. Provet IT supplies the Registration 
Code which is generated from the Key code.  

The Laptop Import Letter  identifies your laptop uniquely to the server. Choose a letter that no 
other laptop on your network performing laptop transfer has used. Type the letter into the Laptop 
Import Letter  box.  

Optional Settings 

The Optional Settings set up the laptop for banking, generation of documents and editing records. 

When the laptop is used in a specific department that Dept number should be entered.  

Once the Mobile laptop is set up, the Mobile laptop options on the Main Menu can be used:  

�  Copy Server Database – to transfer data from the server to the laptop. 

�  Send Changes to Server – to transfer new data from the laptop to the server. 
 

Setting up Terminal Accounts 

Special setup for certain general ledger accounts is required where Terminal Server is used and 
branches process their banking separately or use different bank accounts. If Terminal Accounts 
Defaults are not set up, VisionVPM will use the banking accounts as set in Main menu > 
Maintenance module > Maintenance menu > Account Defaults. 
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��  Set up General Ledger accounts and codes for the Till Account, Safe Account, Eftpos 
Holding Account and Unders and Overs Account for each department (branch) in Main menu 
> General Ledger module > General Ledger menu > Chart of Accounts.  

The Terminal Account number should be your default account as set up in Main menu > 
Maintenance module > Maintenance menu > Account Defaults followed by ~  and the 
number of the department.  

For example, if you have 3 departments and your default Till Account  number is 450 then the 
Terminal Accounts for the Till Account will be 450~2, 450~3, etc. 

If you use different bank accounts at each clinic you will need to set up new Terminal 
Accounts in the General Ledger codes for the Bank Accounts. For example, 401~2 and 
401~3, etc. 

��  Go to: Main menu > Maintenance module > Maintenance menu > System Defaults > 
General System Settings. 

��  Select Use VM with Multiple Clinics through Remote access. 

��  Set up Terminal Account Defaults for each satellite clinic (where the server isn't located) 
where banking will be recorded separately.   

Go to: Main menu > Maintenance module > Maintenance menu > Computer Defaults > 
Terminal Accounts. 

 

��  Click Load Defaults and these numbers will be loaded automatically provided the General 
Ledger Accounts and Codes are in place. 

It is important that the Receipting Department matches your Default Department in the Computer 
Defaults window. 

6.  Click Close to close the window, then Save on the Computer Defaults window to save the 
settings. 
 

Default Appointment Books (This Computer) 

You can select an individual default set of appointment books for each workstation. Individuals 
at different workstations are often focused on different sets of appointments and this facility 
enables them to identify the appointment books they use the most and have these displayed at the 
front.  
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To select Appointment Books Displayed 

Go to: Main menu > Maintenance module > Maintenance menu > Computer Defaults > 
Appointment Books  

 

Settings 

The Appointment Books are created in Main menu > Maintenance module > Maintenance 
menu > Appointments and the default books can also be selected through this path. Up to 20 
appointment books can be selected. 

Select Use individual day setup to enable different day setups for different appointment books. 

The appointment books must be selected consecutively starting with Appointment Book 1, that 
is, Appt Book 6 cannot be selected before all Appt books 1 – 5 have been selected) 

Click Update to save the settings and close the window. 
 

Report Formats 

This function gives access to options for the report format of invoices and other documents. The 
procedure is the same for all reports. Selection of Report Format for an Invoice is used as an 
example. 

Formats can be selected for the following reports: 

�  Invoice 

�  2nd Invoice 

�  Invoice/Statement 

�  Invoice/Statement Email  

�  Statement 

�  After Surgery Care 

�  Estimates 
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�  Balance Sheet 

�  Profit and Loss 

To select an Invoice (Report) Format 

��  Go to: Main menu > Maintenance module > Maintenance menu > Report Formats > 
Invoice. 

 

Settings 

Use this window to select the format for each documents that best suits your clinic needs.  

��  Click Preview to view the item before selection.  

�  'Letter' included in a report format name indicates that the format is designed for a pre-
printed letterhead. 

The Preview button is available on the following windows: 

�  Invoice Report Selection 

�  2nd Invoice Report Selection 

�  Invoice/Statement Report Selection 

�  Statement Report Selection. 

��  Select the preferred report format by double-clicking the selected line.  

��  Click Close to close the window. 
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Note: A report format containing a clinic name indicates that this format has been created for the 
specific clinic. You can select one of these report but please note that if the clinic requires 
changes to the format, you will also have to accept these changes. 

If, after previewing the existing report formats, you decide you require your own format, please 
contact the Provet IT Service Desk to discuss options. 

After Surgery Care letters 

The options for After Surgery Care letters are A4 (or A5) plain or letterhead. The letterhead 
option is used for a pre-printed letterhead. The plain option is for plain paper and prints the clinic 
letterhead details as part of the report. 

Receipt Formats 

Receipts will be printed in the same format as the format that is selected for Invoices. 

 

Codes and Descriptions 

There are many ways in which the VisionVPM system can be customised to meet your clinic 
requirements. Codes and Descriptions allows you to customise options displayed on drop-down 
lists and other items used in VisionVPM. 

Most of the items in the Codes and Descriptions menu are set up in a similar way.  



���
�

�

Go to: Main menu > Maintenance module > Maintenance menu > Codes and Descriptions. 

 

Select the required menu item and a List window for that item will be displayed. For example, 
Stock Location List. 
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The List can be searched by Code or Details for items starting with specified letters or numbers. 
There is also the option to search for an exact match. 

Toolbar 

List windows have similar toolbars with the following options: 

Button Action 

 

Displays a window for insertion of a new record 

 

Enables editing of an existing record. 

 

Displays printing options. 

 

Opens an Excel spreadsheet and exports the list 
information to Excel.  

 

Closes the record.  If the record has not been saved, a 
prompt will be displayed. 

To Insert a New List Item 

��  Click Insert to add a new item. For example, from the Stock Location List, a window for 
inserting a new Stock Location will be displayed. 

 

��  Enter the required Code and Description. 

��  Click Save. 

Note: These windows will vary depending on what information is required. Most will require the 
entry of a Code and Description. 
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To Edit an Existing List Item 

��  To open an existing list item, select the item and click Edit. 

 

��  Make the required changes. 

��  Click Save. 

Button Action 

 

Saves the information entered.  

 

Cancels any changes made. 

 

Deletes the item. 

 
 

Departments 

Departments can be used to: 

�  Categorise client transactions or to assist with stock control. 

�  Define different areas of the clinic where there is a desire to track sales or stock, for example, 
Pet Counter, Farm Counter, Vet's Car. 

�  Track the transactions for different branches of a single clinic. Each clinic entity can also 
have individual departments. 

Using departments facilitates reporting from different areas or branches of the clinic and can also 
be very helpful during stocktaking by grouping stock that should be in the same part of the 
practice. 

To set up Departments 

Multiple departments can be set up within VisionVPM.  
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��  Go to: Main menu > Maintenance module > Maintenance menu > Codes and Descriptions 
> Departments. 

��  Click Insert. 

 

��  Enter the Code. This must be a number; letters cannot be used.  

��  Enter the Name of the department. This should be descriptive enough for the department to 
be easily identified. 

��  If more than one clinic is used in VisionVPM, the appropriate clinic for the department 
should be selected. 

Optional: A general ledger Account Code can be entered for the department. These are set up 
in General Ledger module > General Ledger module > Chart of Accounts. 

 

Vet and User Names 

All users of VisionVPM should be entered into the Vet/User Names area and allocated codes. 
These codes are used to identify veterinarians, for example in patient histories and on drug labels. 
Entering user names also provides opportunities to track individuals' counter sales, to generate 
incentive programs or to facilitate trouble shooting with problem entries in VisionVPM. The use 
of user names can be made compulsory by going to Main menu > Maintenance module > 
Maintenance menu > System Maintenance > System tab and selecting: 

  

The option to prompt to enter vet codes can be selected from System Maintenance > Client tab. 

 

To Enter New User or Vet Names 

��  Go to: Main menu > Maintenance module > Maintenance menu > Codes and Descriptions 
> Vet/User Names. 
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��  Click Insert. 

 

��  Enter a Code for the vets or users that is up to 3 characters long. Initials are generally used.  

��  Select the Vet box if you are entering details for a veterinarian. When filtering client and 
sales reports by Vets, only Vet/User codes flagged as Vets will be displayed. 

Optional: The Inactive box can be selected for any users or vets who no longer work at the 
clinic. 

��  First name and surname should be entered into the Description field.  

��  The colour of the background and the text in the appointment book slots can be selected for 
each user. When several vets are using the same consultation room throughout the day which 
us set up as a single column in the appointment book, this facilitates quick identification of 
which vets are linked to each appointment. 

 

Animal Breeds 

Breeds and species are a means of identifying animals not only in their clinical records, but also 
for the purpose of marketing searches. To use the Marketing Schedule to its full potential it is 
important to prevent several interpretations of a number of breeds or species being entered into 
the database. For example, if a clinic has: German Shepherd and GSD options available, some 
dogs will be entered under each and a search for "German Shepherd" will not identify all the 
dogs of that breed in the database. VisionVPM is supplied with a standard list of Animal Breeds, 
but this may not suit all clinics. 

To stop extra breeds being added unnecessarily as new animals are entered into VisionVPM, you 
should select Disable 'on the fly' breeds by going to Main menu > Maintenance Module > 
Maintenance menu > System Defaults > Clients tab. The result of this will be that Animal 
Breeds cannot be added or edited anywhere in VisionVPM except through Main menu > 
Maintenance Module > Maintenance menu > Codes and Descriptions > Animal Breeds.  

To Insert a New Animal Breed 

��  Go to: Main menu > Maintenance module > Maintenance menu > Codes and Descriptions 
> Animal Breeds. 
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��  Click Insert. 

 

��  Enter a Code.  

��  Enter the name of the breed in the Description box. 

��  Select the Species from the drop down list. 

Each breed should have a species linked as this will populate the species field on the Animal 
Details window automatically when the breed is selected. 

��  Click Save. 
 

Clinical Descriptions 

A standard list of clinical descriptions is included in VisionVPM. These may not suit all clinics. 
Existing descriptions and codes can be edited or deleted and new clinical descriptions can be 
added. 

Clinical Descriptions are used from the Desc. List tab when entering clinical records. 

 

Selecting items from the clinical descriptions list while entering clinical notes will assist in 
improving the consistency of data entry in the clinical records, by removing the need for 
abbreviations, eliminating spelling errors and standardising terminology. This will make searches 
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more efficient and facilitate use of the marketing schedule. For those who are less proficient at 
typing, using pre-define clinical descriptions can speed up data entry and improve accuracy. 

Some examples of clinical descriptions used are: 

 

To Insert a New Clinical Description 

��  Go to: Main menu > Maintenance module > Maintenance menu > Codes and Descriptions 
> Clinical Descriptions. 
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��  Click Insert. 

 

��  Enter a Code for the Clinical Description. 

��  Enter the details of the Description. 

Optional: select the Species to which the description will apply. The description item will 
only be displayed when the clinical record is for an animal of that species. 

Optional: select a reminder to link with the description and set the time interval for the 
reminder. 

��  Click Save. 
 

Invoice Messages 

Invoice Messages include messages printed on Client invoices and/or invoice/statements and 
messages related to individual stock items that are printed on invoices when those stock items are 
sold.  

Default messages for statements or invoices can be chosen, for example, a bank account number, 
a greeting, or a promotional message. Specific messages can be added to 1 month overdue, 2 
month overdue or 3 month overdue statements.  

Stock messages can be used on invoices to add value, for example, by giving a description of the 
procedure, or useful information when using the item that has been purchased. 

There are no invoice messages pre-loaded in VisionVPM. 
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To Insert a New Invoice Message 

��  Go to: Main menu > Maintenance module > Maintenance menu > Codes and Descriptions 
> Invoice Messages. 

 

��  Enter the Code for the message. As only the message codes are displayed in the Invoice, 
Statement or Stock Details windows, it is helpful if the codes are as informative as possible.  

��  Enter the full message in the Message box. 

��  Optional: Click Default to make this message the default invoice message. 
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Once set up, stock messages can be can then be selected from the Stock details window for the 
relevant stock item.  
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Stock messages are displayed in the body of the invoice under the listing for the stock item to 
which they are linked. Invoice messages are displayed at the bottom of the invoice. 

 

Default invoice messages can be applied by using the default option or by clicking the Message 
button on the right side of the Invoice window. 

 



4��
�

�

Statement messages can be selected at the time of printing the statements by using the list arrows: 

 
 

Client Markers 

Client Markers are a useful tool for identifying different types of clients in your database so you 
can find them later, particularly for marketing purposes. Client markers allow clients to be 
grouped and selected for reporting, marketing and discount purposes. In the Marketing Schedule, 
markers can be used to include or exclude clients from marketing searches. Clients can have 
multiple markers, for example, P for pensioner, C for being a dog owner and J for living in Judea. 
Markers can be added from the Marketing Schedule during searches. Standard markers can be set 
up through the Maintenance module. 

To Insert a New Client Marker 

��  Go to: Main menu > Maintenance module > Maintenance menu > Codes and Descriptions 
> Client Markers. 

 

��  Enter a Code.  
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�  Client markers are 1 character long and can be a single number, letter or mathematical 
symbol. 

�  Upper case letters are recognised as different to lower case letters. 

��  Enter a Description for the marker.  

�  The description should fully describe what the marker relates to, for future clarification. 

Client markers can be added to individual clients on the Client Details window by clicking the 
Marker arrow, and then double-clicking to select. 

 
 

Sire Codes 

Sire details are important for the identification of breeding horses and their offspring.  

Sire codes are only used for equine records and can be applied from the Equine Details window.  

A Location Code or a Sire Code must be in place for a record to be recognised as an equine 
record.  

To Insert a New Sire Code 

��  Go to: Main menu > Maintenance module > Maintenance menu > Codes and Descriptions 
> Sire Codes. 
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��  Click Insert. 

 

��  Enter a Code for the sire. 

��  Enter the sire's name in the Description box. 

��  Click Save. 
 

Location Codes 

Location codes are used for horses as many may be stabled at a different address to that shown in 
the client's contact details. A Location code or Sire code must be in place for a record to be 
recognised as Equine.  

To set up a Location Code 

��  Go to: Main menu > Maintenance module > Maintenance menu > Codes and Descriptions 
> Location Codes. 

 

��  Enter a Code for the Location.  

��  Enter a Description for the Location. 

��  Enter the Distance from the clinic to the Location.  

�  When a distance from the clinic is entered, it enables VisionVPM to calculate mileage 
charges for this location for invoicing.  

�  Location distance has precedence over client mileage when invoicing. 
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��  Click Save. 
 

Estimates 

Commonly used estimates can be set up as templates which can then be customised for the 
individual client or animal.  

There are three steps to setting up estimates. These are: 

��  Setting up Introduction and Conclusion Messages 

��  Setting up Estimate Types. 

��  Selecting an Estimate Report type. 

Setting up Introduction and Conclusion Messages 

Go to: Main menu > Maintenance module > Maintenance menu > Codes and Descriptions > 
Estimates > Estimate Messages. 

Introduction 

��  Click Insert and type a Code for the Introduction, for example, CRUCINTRO, for a cruciate 
introduction. 

��  Select Introduction to letter  and press TAB. 

 

��  In the Text box enter the introduction that you want to appear on the estimate. 
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��  Clicking Field List. will display a list of fields available for merging. 

��  To set this message as the default introduction message, click Set Default Introduction. 

��  Click Save. 

Conclusion 

Conclusion messages are created in the same way as introduction messages except that you select 
Conclusion to letter. 

Use the Field List button to select fields you want to have personalised and choose the Vet 
Name to finish off the letter. 

 

Setting up Estimate Types 

Pricing templates can be created for estimates. 

��  Go to: Main menu > Maintenance module > Maintenance menu > Codes and Descriptions 
> Estimates > Estimate Types. 
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��  Click Insert. 

 

��  In the Type box, type a code for the estimate you wish to create, for example, CRUC for 
Cruciate Surgery. 

��  In the Description box, type the name that will appear in the letter, for example, Cruciate 
Surgical Procedure for Medium Dogs. 

��  In the Introduction box, click Message then double-click to select the Introduction message 
that you require in the estimate letter. 

��  Click the Stock arrow and then select the stock items (procedures and products) that will be 
charged in this estimate. 

�  If a line needs to be edited or changed, double-click the line to bring it into the Entry 
boxes. The line can then be edited there. Use ENTER to add it to the Estimate letter 
again. 

	�  In the Conclusion box, click Message, and then double-click to select the Conclusion 
message you wish to be displayed in the estimate. 


�  Click Save.  

Estimate templates can also be created at the time of creating an estimate for a client. 

Setting up an Estimate Report Type 

This allows you to select the format for your estimate. 
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��  Go to: Main menu > Maintenance module > Maintenance menu > Codes and Descriptions 
> Estimates > Estimate Reports. 

 

��  Double-click the required format. 

��  Click Close. 
 

Clinics 

Clinics are used in VisionVPM when a practice has multiple branches and within those branches 
they want to use separate departments for reporting purposes. 

For example: 

Clinic Level  Tauranga A         Tauranga B            Tauranga C 

      |          |      |   | 

      |          |      |   | 

Department Level Shop, Vet Clinic          Shop, Vet Clinic          Shop, Vet Clinic 

To Set up a Clinic 

��  Go to: Main menu > Maintenance module > Maintenance menu > Codes and Descriptions 
> Clinics. 
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��  Click Insert. 

 

��  In the Clinic Name box, type the name of the clinic. 

�  The Address, Phone and Email fields will only be used if you are using Terminal 
Services. 

�  When using Terminal Services, the above fields will be displayed on client invoices. 

��  Click the Default Hospital arrow to select a default hospital if you wish to use different 
hospital names for each clinic. 

��  Click Save. 
 

Stock Letters 

These letters are attached to stock items and are automatically generated when that stock item is 
sold.  

An example of this is an After Surgery Care Letter (with information about how to care for the 
animal at home) attached to a gaseous anaesthesia stock item. 

Procedure  

��  Check settings in Maintenance. 

��  Create a stock letter. 

��  Attach the letter to a stock item. 
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Check settings in Maintenance 

��  Go to: Main menu > Maintenance module > Maintenance menu > System Defaults 
>Financial/Client Invoicing. 

 

��  Select Prompt for stock letter printing . 

��  Click Save. 

�  When a stock item is sold which has an after surgery care letter attached, VisionVPM will 
prompt the user to print the letter. 

There are three options for creating stock letters using the following: 

��  Word document 

��  Wordpad document 

��  VisionVPM text editor (no formatting options). 

Set up stock letters 

Where Wordpad has been selected for documents in Maintenance > Computer Defaults, the 
Use a Wordpad document option will be displayed: 

 

If you have not selected to use Wordpad and a Path to Word has been entered in Maintenance 
> Computer Defaults, the Use a Word document option will be displayed: 
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If you do not have either Word or Wordpad you will need to use the VisionVPM text editor 
selecting the Use the letter details field below option: 

 

When Use a Word document is selected, a Word document can be located or modified using the 
File Name field and buttons at the bottom of the window. The Wordpad option works in a 
similar way. 

To create a new letter using either Word or Wordpad  

��  From the Stock Letter window, select Use a Word document or Use a Wordpad document. 

��  Click New Letter. 

 

��  Type a name for the letter and click OK. 

��  When the Word or Wordpad opens, type the required text and select available merge fields as 
required. 

��  Save the document when completed. 
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To convert an existing stock letter to Word or Word pad 

��  From the Stock Letter window, copy the existing stock letter. 

��  Select Use a Word document or Use a Wordpad document. 

��  Click New Letter at the bottom of the window. 

��  Enter the name of the new document and click OK. 

��  Paste your existing stock letter into the new Word or Wordpad document. 

�  You will be required to re-insert the merge fields within the document. 

�  Save your document and it will then become available for selection in the File Name list. 

��  Click the File Name arrow and select the new document. 

	�  Click Save. 

To modify an existing Word or Wordpad letter 

��  Select Use a Word document or Use a Wordpad document. 

��  Click the File name arrow and select the required document. 

��  Click Modify Letter.  

The letter will be opened in Word or Wordpad for editing. 

To view existing Word or Wordpad stock letters 

��  Select Use a Word document or Use a Wordpad document. 

��  Click Browse Folder. 

�  Your stock letters will be displayed. 

To create a Letter using the VisionVPM text editor 

��  Go to: Main menu > Maintenance module > Maintenance menu > Codes and Descriptions 
> Stock Letters. 

��  From the Stock Letter List Details, click Insert, and in the Code box, type the code for the 
after surgery care letter. 

��  In the Letter Title box, type the description of the letter. 

��  In the Letter box, type the details of the letter. 

�  Optional: Merge fields can be added to the letter. Select the required field in the box on 
the right side of the window and double-click on it to insert. 

��  Click Save. 

Attach letter to a stock item 

��  Go to: Main menu > Stock module > Stock menu > Stock Details > select stock item. 
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��  Click the Letter Code arrow, and then double-click to select the stock letter you wish to 
attach to the stock item. 

 

��  Click Save. 
 

Autobanking Setup 

Autobanking allows you to use desk-top banking to pay your Suppliers and/or your Employees. 
The Autobanking facility is currently only available to New Zealand users. 

The transactions are entered into an autobanking file which can then be transferred to your 
banking software, eliminating double-handling. The transactions will still appear on your bank 
reconciliation. 

To set up Autobanking 

��  Go to: Main menu > Maintenance module > Maintenance menu > Codes and Descriptions 
> Autobanking Setup. 

��  Click Insert. 

 



%%�
�

�

��  Select I want to use autobanking for my supplier payments to set up autobanking for 
suppliers. 

��  Select I want to use Autobanking for my payroll to set up autobanking for payroll. 

��  Select the Bank you use. 

��  Enter your Company's name in the Your Company Name field. 

	�  In the Default Output file name field, enter a path where the autobanking file will be saved 
to, for example, c:\Omnis7\Banking\Autobanking.txt. 

�  If you require a separate autobanking file for your payroll payments, enter the path for this 
file in the Payroll Output file name field. 

�  If you use autobanking for supplier and payroll payments, it is recommended that you set 
up a file for each type of payment, in order to keep the payments separate.  

�  If you only have the one file, this file will be overwritten each time you process either 
supplier or payroll payments. 


�  In the Bank Account Code field, enter the general ledger code for your bank account. 

��  Enter your bank account number in Your Bank Account Number field. 

Note: A BNZ bank account number is 15 characters long. 

��  Click Save. 
 

Custom Fields 

Custom Fields allow clinics to track additional options for clients and animals. These can be used 
for marketing purposes or quick identification of a specific item, for example, the animal's 
preferred food. 

There are four custom fields available for clients, animals and equine records. 

Each animal species can have its own set of custom fields and these specific fields will take 
priority over general fields.  

To set up or edit Custom Fields 

��  Go to: Main menu > Maintenance module > Maintenance menu > Codes and Descriptions 
> Custom Field. 
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��  Click Insert. 

 

��  In the Field Name, enter a name for the custom field. 

��  Select whether this custom field relates to Client, Animal or Equine. 

��  In Field No (1-4) type the number of the field which defines where it will be displayed on the 
Client Details, Animal Details or Equine Details window.  

�  Client Custom Fields 1 and 2 are displayed on the Main tab of the Client Details 
window. 

�  Client Custom Fields 3 and 4 are displayed on the Settings tab of the Client Details 
window. 

��  To attach a species to a animal custom field, click the Species arrow and double-click to 
select a species. 

�  For animal fields it is important that all breeds are associated with a species. 

	�  In the Add to List box, enter the selections for the custom field. Press ENTER after adding 
each selection to display the option in the Field Options list. 


�  When all field options have been entered, click Save. 
 

Hospitals 

Hospitals can be created to separate the different areas where animals can be admitted, for 
example, Hospital, Grooming, Surgery. Where there are multiple clinics using VisionVPM and 
more than one hospital, a separate hospital can be set up for each clinic.  

To create a Hospital 

��  Go to: Main menu > Maintenance module > Maintenance menu > Codes and Descriptions 
> Hospitals. 
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��  Click Insert. 

 

��  Enter the Hospital Name.  

��  To select the hospital as the Default Hospital, click Default to display the prompt.  

 

��  Click Yes. 

��  Click Save. 
 

Clinical Analysis Groups 

Clinical Analysis Groups allow selected clinical records to be grouped together for analysis. For 
example, if you are doing a study on a clinical condition, you can link the relevant records of any 
animals with that condition using a clinical analysis group. That clinical analysis group can then 
be used in a Marketing Schedule search. 

The clinical analysis group is attached to the record through the Groups tab on the Clinical 
Record window. 

To set up a Clinical Analysis Group 

��  Go to: Main menu > Maintenance module > Maintenance menu > Codes and Descriptions 
> Clinical Analysis Groups. 
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��  Click Insert. 

 

��  In the Description field, type a description for the Clinical Analysis Group. 

��  Click Save. 
 

PACS Modality 

PACS are Picture Archiving and Communication Systems and are servers dedicated to the 
storage, retrieval, distribution and presentation of medical images. 

An interface to a PACS system provided by Central Data Networks (CDN) is available through 
VisionVPM. The PACS interface is available through Provet IT for clinics using the CDN PACS 
system.  

To Set up for PACS Modality 

��  Go to: Main menu > Maintenance module > Maintenance menu > Codes and Descriptions 
> PACS Modality. 

��  Click Insert. 

  

��  In the Code box, type the code for PACS Modality. 

��  In the Name box, type the name for the PACS Modality. 

��  Click Save. 
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Client Address Locations 

Entering suburbs, cities or towns and the postcodes they are associated with will provide a list of 
suburbs to speed up data entry processes and promote consistency within your database. 

The suburb list can be used to complete the address in the Client Details window. 

To create a Client Address Locations 

��  Go to: Main menu > Maintenance module > Maintenance menu > Codes and Descriptions 
> Client Address Locations. 

��  If the Type field in Maintenance > Company Information is set to 0 (New Zealand) the 
following window will be displayed. 

 

��  If the Type field in Maintenance > Company Information is set to 1 (Australia) the 
following window will be displayed. 

 

��  In the Suburb or Town/City  field, type the name of the suburb or town/city. 

��  Click the City or State arrow and select the city or state. 
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�  If the required city or state is unavailable, in the City or State field, enter the name for the 
city or state. 

��  In the Postcode field, type the postcode number. 

	�  Click Save. 

Default address settings can be loaded in Main menu > Maintenance module > Maintenance 
menu > System Defaults > Client tab > Client and Patient Settings. These will save you time 
when entering new clients if they majority of your new clients are located in the default address 
locations. 

New Zealand Client and Patient Settings: 

 

Australian Client and Patient Settings: 

 
 

Referral Vets 

These windows allow the details of referral vets to be stored so they can quickly and easily be 
linked to animals when referred.  

To Set up a Referral Vet 

��  Go to: Main menu > Maintenance module > Maintenance menu > Codes and Descriptions 
> Referral Vets. 
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��  Click Insert. 

 

��  In the Vets Full Name and First Name fields, enter the vets name and first name. 

�  First Name is available as a merge field when creating merge letters. 

��  In the Hospital Name and address fields, type the name of the hospital and address details. 

��  In the Phone and Fax fields, type the corresponding numbers. 

��  Click Save. 

�  Animals can be linked to the referral vets on the Animal Details window.  
 

Boarding Suites 

Boarding facilities can be organised into rooms or areas, each of which has a number of units, by 
using the Boarding Suites window.  

Once the boarding suites are created, the Boarding Scheduler will show each suite with the 
number of cages available. 

To create Boarding Suites 

��  Go to: Main menu > Maintenance module > Maintenance menu > Codes and Descriptions 
> Boarding Suites. 
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��  Click Insert. 

 

��  In the Suite Name field, type the name you want to give to this range of cages. 

�  For example, Large Dogs. 

��  In the No. of Suites field, type how many of these cages you have. 

�  For example, you may have a cat area with 20 cages, an area for large dogs which only 
takes 4 large dogs and another area which will take 10 small to medium dogs.  

�  When these cages are loaded as separate suites, you will be able to see at a glance whether 
you have room for another cat or dog when a client calls to book. 

��  Click Save. 
 

Stock Locations 

Stock locations can be created to allow identification of the location of stock within the clinic. 
This can assist staff finding stock on a day to day basis. It can also be useful during stocktaking. 

To set up Stock Locations 

��  Go to: Main menu > Maintenance module > Maintenance menu > Codes and Descriptions 
> Stock Locations. 

 

��  Enter a Code and Description. 
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�  The Code should be as informative as possible as only the code is displayed on the Stock 
Details window.  

 
�  The Description should provide extra information regarding the location. 

�  Stock Locations may be as general as different areas of the clinic, for example, Pet Store, 
Farm clinic or as specific as certain shelves. The Stock Location list can be accessed from 
the Stock Details window. 

 

Quick Access Menu Setup 

Quick Access is an option that is always available on the main toolbar. The Quick Access Menu 
offers shortcuts to regularly used items from a single menu. 

The fixed options are: 

 

To customise the Quick Access Menu in order to set up quick access keys to navigate to 
commonly used VisionVPM features: 

��  Go to: Maintenance > Quick Access Menu Setup. 

��  Click Yes to the following message if you only want to set up the Quick Access menu for the 
computer you are using. 
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��  The following window will be displayed. 

 

��  You can either click or drag and drop the menu item into the ID area on the right or type the 
menu item number. 

��  Click Save. 

The Quick Access Menu will now display the customisations.  
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Users Access 

The Password System in VisionVPM allows different users to have access to specified parts of 
the program, for example, Clients, Suppliers, Stock etc. When the password system is enabled, 
each time a user logs into VisionVPM they will be asked to enter their user code and password. 
They will then be allowed access to the parts of the program allocated to that User. 

The password system does not track activity. This means that you can't say if a particular user 
was in the program at a particular time. 

It is common practise for access to the Maintenance and General Ledger modules to be restricted 
to a small number of users. 

It is important that there is someone at the clinic who has access to the administrator code so 
Provet IT can give support in all areas of VisonVPM. For example, Maintenance and General 
Ledger module access is often required when there are banking issues.  

To Insert a New User or to Change User Access 

��  Log on to VisionVPM with a user name that has administrator access.  

If the user name and/or password cannot be recalled, please contact Provet IT for assistance. 

��  Go to: Main menu > Maintenance module > Maintenance menu > Users Access. 

 

To Set up Administrator 

This sets up a code for someone that has full access rights to the entire program. 

��  Highlight the ADMIN line in the Users List window and click Edit .  
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A User Setup window will be displayed. 

 

��  Leave the User as Admin and change the Password to one of your choice.  

��  Click OK. 

To create Users  

You can choose to set up a user for each staff member or you can set up access for groups of 
users who require a certain level of access. 

��  From the Users window click Insert. 

��  In the User and Password fields, type a user or group name, for example, Nurse and a 
password. 

��  Click Set Access. 

 

��  Select the items that you wish the user to have access to. 

'On the fly' refers to changes made to lists while entering data, rather than having to go 
through the Maintenance module to make changes. While this speeds up data entry, the 
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potential for multiple entries where there should be a single one, for example, due to 
misspelling or abbreviations, is increased. 

��  Click Close, then Click OK on the User Setup window. 

��  Once all users have been set up, select Turn the Password System on. 

	�  The following warning will be displayed: 

 


�  Click Yes to continue and then click Close. 

VisionVPM is now password protected and a username and password will be required for access. 
Users will not have access to any locations or actions that have not been selected for their 
username. 
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Database Maintenance 

Database Maintenance offers many ways of dealing with groups of data to facilitate data entry, 
management and investigation of possible data errors. 

Many of these processes are used to detect or solve specific data problems and should only be 
used in consultation with Provet IT Service Desk staff. 

There are useful routines for clinic database maintenance for example, Delete Clients/Stock 
Suppliers, Set Client Discounts, Increase Stock Prices. 

Because of the risk of permanently deleting transactions, altering transactions and changing 
database settings, only those users in your clinic who have the authority to make these changes 
should have access to Database Maintenance. This can be implemented by using the password 
system and Users Access options in the Maintenance module. 

 
 

Check Transactions 

This window is very useful for finding missing transactions and for checking transactions.  

��  Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance 
> Check Transactions. 

 

��  Click on any of the column headers to sort the list by that column. For example, to sort 
transactions in date order, click Date. 

The following table lists the column headers and their definition: 
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Seq The sequential number of the transaction. The sequential number can 
assist you in sorting transactions in the order in which they occurred. 
This is useful for determining if transactions have been deleted. 

Code The code entered on the transaction. If no code is entered, the Code 
will be displayed as the Seq number. 

Type The transaction type. The following is a list of transaction types in 
VisionVPM: 
Cashbook (Cashbook deposits, Cashbook payments, EFTPOS 
Deposits, Deposits to Bank Account, Unders & Overs Adjustments) 
Journal (Journal entries, Stock Adjustments, Transfers to Safe, 
Depreciation entries, Zero Stock Takes) 
Cr Invoice (Supplier invoices) 
Cr Payment (Supplier payments) 
Dr Invoice (Client invoices) 
Dr Payment (Client payments) 
St Transfer (Stock transfers) 
Payroll (Payroll entries - NZ clients only) 
On Order (stock items downloaded from hand held scanner - e-Order). 
Good Rec (Goods receipts) 
Budget (Budget entries) 

Date The date that was entered on the transaction.   
Clinic Displays the clinic code. 
Total Displays the $ amount of the transaction. 
Change Date The date the transaction was entered or the last date the transaction was 

changed. 
Details Displays the description of the transaction. 
Error The Error column will be displayed when you move the vertical scroll 

bar to the right. 
The Error column is used in conjunction with the Check Entries 
function and will list details of the data errors of the transaction. 

The following table describes the functions of the buttons on the sidebar: 
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Opens the previously saved list. 

 Saves the displayed list so that it can be reopened at a later time. 

 Deletes the selected entries from VisionVPM.  
Please note that deleting transactions from VisionVPM is a non-
reversible permanent change.  
When deleting transactions you MUST ensure that you are deleting the 
correct transaction and that you definitely no longer require this 
transaction. 

 
Clears the lines from the list (but NOT from the database). 

 Displays a list of all transactions between the dates entered.  There is 
an option to display transactions by change date. 



���
�

�

 
 Checks for incorrect entries between dates entered 

 
 For data transfer clinics. 

 

 

 

 Will display all Cost of Sales journals for the selected date range. 

 Enables the user to search for links 

 

 Prints the list of displayed transactions. 
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Displays the detail of the selected line. 

 
 

Reorganise Data 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Reorganise Data. 

 . 

This routine is used to ensure that changes to the table structure in VisionVPM are sent through 
to the database. This function happens automatically with new updates where the database 
version number changes. 

Please ensure that you have a current backup file before performing this function. 

 

General Maintenance 

General Maintenance options are functions which apply to more than one of the VisionVPM 
modules. 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
General Maintenance. 
 

Mixed Case Names 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
General Maintenance > Mixed Case Names. 

 

This procedure will change the details for names so that all words in the name start with a capital 
letter and the remaining letters are in lower case. For example, if previously your client 
firstname, lastname, address were displayed in lower case letters, after running this procedure, all 
details will be displayed with the first letter of each word being a capital letter.  

VisionVPM will autocorrect any new entries so that all names start with a capital letter and 
continue in lower case. 

Running this procedure will affect fields on the following windows: 
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�  Client Details 

�  Animal Details 

�  Stock Details 
�  Account Details (General Ledger module). 
 

Recreate Autobanking APs 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
General Maintenance > Recreate Autobanking APs. 

 

This procedure will regenerate the autobanking entries for supplier payments for a selected date. 

Once the routine has completed you can view the entries in Main menu > Auto Banking. 
 

Write Non Dept Entries 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
General Maintenance > Write Non Dept Entries. 

 

This routine enables you to enter a department code on transactions. You would normally run this 
procedure when you move from not using departments in your database to a database containing 
multiple departments. 
 

Clear Old Transactions 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
General Maintenance > Clear Old transactions. 
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This routine enables you to clear old transactions from a selected date prior to the Year Begins 
date. Only financial transactions are removed from the history, NOT clinical records. This frees 
up the memory available. 

 

This procedure would normally be run in conjunction with the End of Year Rollover procedure 
in Main menu > Maintenance module > Maintenance menu > End of Year Rollover. 
 

Write Cr and DR Control 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
General Maintenance > Write Dr and Cr Control  

 

The procedure will write a specific marker into the DR and CR control lines on invoices and 
payments. It should only be used in conjunction with advice from the Provet IT Service Desk. 
 

Convert Adhocs 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
General Maintenance > Convert Adhocs 

 

This procedure will convert the adhoc reports to the correct Omnis7 version. 
 

Missing Entries 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
General Maintenance > Missing Entries 
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This procedure Identifies transaction errors and displays them in a report. You have the option to 
delete all of the displayed items. 

 

Click Yes. 

 

Click Yes to display the Set Report Destination window with printing or viewing options. 

 

Click Yes to delete. 
 

Delete Clients/Stock/Suppliers 

This option identifies clients, stock or suppliers to delete from your database based on absence of 
activity. It allows a number of inactive stock items, clients or suppliers to be identified and 
deleted in one procedure. 

��  Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance 
> General Maintenance > Delete clients/stock/suppliers. 
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��  Select whether you are searching for clients, suppliers or stock to delete and check the 
appropriate box. 

 

��  Click Build List  to generate a list. 

�  Clients and Suppliers who do not have financial history since the Year Begins date 
(displayed in Main menu > Maintenance module > Maintenance menu > Company 
Information ) will be displayed. 

�  Stock items that have not been invoiced since the Last Invoiced before date will be 
displayed. 

��  Any lines which you don't wish to delete from VisionVPM can be cleared from the list by 
clicking Clear Lines. 

��  The list can be printed by clicking Print . 

��  Delete records by highlighting the records to be deleted and then clicking Delete Records. 

The selected records will be permanently removed from VisionVPM. 
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Copy Appointments to New System 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
General Maintenance > Copy Appointments to New System. 

 

This option is used to copy appointments from the tab-style appointment book to the column-
style appointment book. This procedure should be performed ONLY ONCE, otherwise duplicate 
appointments will be created. 
 

Delete Duplicate Animal Activity 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
General Maintenance > Delete Duplicate Animal Activity 

 

This procedure will delete duplicate duplicate transactions in an animal's activity. 
 

Estimate Entries 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
General Maintenance > Estimate Entries. 

 

This procedure will check that all invoices have been correctly created from estimates. 
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Transfer Between Departments 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
General Maintenance > Transfer between Departments 

 

This procedure will transfer all entries from a specified department to another department. 
 

Add F_AdhocFields to Adhocs 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
General Maintenance > Add F_AdhocFields to Adhocs 

 

This procedure allows you to insert specific adhoc fields into your adhoc reports. 
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Float Adhoc Reports 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
General Maintenance > Add F_AdhocFields to Adhocs >  Float Adhoc Reports. 

 

This procedure allows you to have greater flexibility in line placement of fields in your adhoc 
reports. 

 
 

Copy Computer Defaults 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
General Maintenance > Add F_AdhocFields to Adhocs >  Copy Computer Defaults. 
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When VisionVPM is reserialised on your computer with a different Omnis license number, the 
computer defaults will be altered. This option allows the computer defaults to be reinstated from 
another licensed computer without having to manually record and re-enter the settings. 

 
 

Client Maintenance 

The Client Maintenance options assist with client data. These options enable you to work with 
many clients at once rather than using the individual Client Detail windows. 

 
 

Rebuild Client Markers 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Client Maintenance > Rebuild Client Markers. 

 

This procedure will check all markers for clients, making sure that they still exist. It also deletes 
any excess commas in the Marker  field. 
 

Rebuild Client Activity 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Client Maintenance > Rebuild Client Activity.  

 

This procedure writes the DR Entry table if it is missing. This happens very rarely.  
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This routine should only be run in conjunction with advice from the  team. 
 

Charge Member Fees 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Client Maintenance > Charge Member Fees. 

This procedure is used to charge a set fee to a group of clients. For example, Vet Club Members. 

 

If there are to be different fees for different marker groups or different departments, then each 
data set has to be entered separately. 

Enter relevant information into the fields provided. 

The GL Sales code is for the account to which the fees will  be allocated. 

The Description on Invoice is the entry that will appear on the client invoice. 

Click OK to apply. The fee will be added to the selected clients' activity as an invoice on the date 
entered. 
 

Select Clients for Interest 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Client Maintenance > Select Clients for Interest. 

 

When this routine is run, all clients with an account fees marker will also be marked for interest 
fees. Contact Provet IT before running this routine. 
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Move Company Name 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Client Maintenance > Move Company Name. 

 

This was a routine for those who used VisionVPM before a Company Field was available on the 
client window. 

First specify the Custom Field where the Company names are located, then VisionVPM can 
transfer them. 

When clinics enter data directly into the Company field there should be no requirement for this 
routine. 
 

Set Client Discounts 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Client Maintenance > Set Client Discounts. 
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This procedure will set the Discount Multiplier  in the Settings tab of the Client Details window, 
to 1, for those clients where the Discount Multiplier  was 0. 

 
 

Update Animal Codes 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Client Maintenance > Update Animal Codes. 

 

This procedure will change any animal codes that do not already fit the format: First 4 letters of 
the animal's name and first 6 letters of the client's last name (or Company name). All codes will 
be unique. 
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Link Animals to Reminder 

IT Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance 
> Client Maintenance > Link Animals to Reminder. 

 

This procedure will attach unlinked reminders to the correct animal. This procedure should only 
be run as directed by the Provet IT Service Desk. 
 

Delete Duplicate Reminders 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Client Maintenance > Delete Duplicate Reminders. 

 

This procedure will delete all duplicate animal reminders.  

Note: VisionVPM will only delete duplicates where the duplicates have the same reminder code. 

 
 

Add Groups to Clinical Records 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Client Maintenance > Add Groups to Clinical Records. 
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Duplicate PARs 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Client Maintenance > Duplicate PARs. 

 

This procedure will create copies of PAR authorities for all existing PAR authorities within a 
specified date range.  

 

The new PAR authorities will have a start and end date one year on from the original PAR start 
and end dates. 

This might be used for updating seasonal PAR authorities where there is little or no change. 

Note: this routine does not give the opportunity to view or check the PAR authorities before 
updating. 
 

Check Estimate Types 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Client Maintenance > Check Estimate Types. 

 

This procedure will check and update estimates and checking that the estimate totals are correct. 
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Remove Speech Marks 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Client Maintenance > Remove Speech Marks. 

 

Speech marks in the name or address fields can sometimes interfere with the merge functionality. 
This routine was put in place to search for speech marks in these fields and remove them. 

When the routine is run, the following prompt is then displayed: 

 

Click Yes to correct any duplicate client codes. 
 

Delete Duplicate F_Dr_Entry 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Client Maintenance > Delete Duplicate F_Dr_Entry. 

 

This procedure will delete all duplicate client transactions. This should be done in conjunction 
with advice from VisionVPM. 
 

Convert eWizard letters to VPMMail 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Client Maintenance > Convert eWizard letters to VPMMail. 

 

This routine was made available when VPMMail was introduced to convert existing email letters 
to VPMMail letter format. 
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Validate email Addresses 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Client Maintenance > Validate email Addresses. 

 

This routine in VisionVPM will check and print any invalid email addresses in your database. 
VisionVPM will check your email addresses against the following criteria: 

��  No Spaces allowed. 

��  Must contain an @ symbol. 

��  Must be a full stop in the 2nd part of the address after the @ symbol. 

��  Must be a name before the @ symbol. 

��  First character cannot be a full stop. 

��  Last character cannot be a full stop. 

	�  Length of the 2nd part of the address after the @ symbol must be greater than 1. 

An example of the report is below. 

 

You should then change any incorrect email address from the Client Details window. 
 

Split out Postcodes 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Client Maintenance > Split out Postcodes. 
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This routine helps you move postcodes from other address fields to the post code field. 

Note: After you have run this procedure you will need to add the post code field to and merge 
documents or adhoc files you use. 
 

Clear Custom Fields 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Client Maintenance > Clear Custom Fields. 

Clinics may choose to utilise Custom Fields for a different data set. However, the data loaded 
under the previous Custom Field remained, when the Custom Field name was changed, even 
though it may have been irrelevant.  

This routine allows you to remove data from a selected client, animal or equine custom field. 

When the Custom Field is required for a different data set, this routine can be used to clear any 
existing data from the Custom Field on the Client Details or Animal Details windows. 

 

��  Select the Custom Field. 
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��  If it is an Animal Custom Field, make the required animal selections. 

�  All Animals  - will remove data from selected custom field. 

�  Equine Only - will remove selected custom field data from equine records only. 

�  All Animals excluding Equine - will remove selected custom field data from all animals 
records except equine. 

�  Selected Species - will only remove data for the selected custom field with the selected 
species. 

��  Click Clear Data. 

��  Click Close. 

 

Stock Maintenance 

The Stock Maintenance options assist with stock data. These options enable you to work with 
many stock items at once rather than using the individual stock detail windows. 
 

Increase Stock Prices 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Stock Maintenance > Increase Stock Prices. 

 

Click Yes to continue. 

This option enables you to adjust the prices of a number of stock items at once. A percentage 
increase can be applied to the Mark-up or the sale price. 

Any prices changes will only be applied to stock items - not professional fees.  The prices 
changes can also be applied to stock components of formulations.  
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Alternatively a set markup percentage can be applied across a number of products selected by 
either sales code or analysis group. 

 

��  Select whether you want to Use a percentage increase or Use a set markup percentage. 

�  Use a percentage increase 

�  In the Increase by field, enter the percentage by which you want the markups or sales 
prices increased. 

�  Select Increase Markups or Increase Sale Price (exc GST). 

�  Optional: Use the list arrow to select the GL Sales Group or Analysis Group to which 
you want this price increase applied. 

If you do not select a sales group or an analysis group the percentage increase will be 
applied to all stock items. 

�  Use a set markup percentage 

�  In the New Markup Amount field, enter the new markup you want to be applied. 

�  Use the list arrow to select the GL Sales Group or Analysis Group to which you want 
the new markup applied.  

To set a markup percentage you must select a sales group or analysis group. 

��  Select Update formulations/ estimate types when a component increases if you want the 
prices of components within formulations to be increased. 

This will only happen when the individual formulation also has Automatically update when 
component price changes selected. This will only increase the price of the stock items 
within the formulations, not the professional fees. 

 

��  Click OK to apply the price changes. 
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Increase Professional Fees 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Stock Maintenance > Increase Professional Fees. 

 

Click Yes to continue. 

Professional fees are those stock items that do not have a pack cost. 

 

��  Enter the percentage by which you wish to Increase the professional fees. 

��  Enter the code for a GL Sales Group or Analysis Group if you only want the increases to 
apply to a single sales group or analysis group. 

��  Tick Update formulations / estimate types when a component increases if you wish your 
formulations to be updated automatically. This will only increase the professional fees within 
those formulations, but not if the professional fee is a component of its own formulation. 

If the price update for professional fees within formulations is to occur, the Automatically 
update when component price changes check box in the stock formulation window must 
ALSO be selected. 

 

��  Click OK to apply the fee changes. 
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Calculate Average Stock Purchase 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Stock Maintenance > Calculate Average Stock purchase. 

 

This procedure will update the average cost price for all stock items from a selected date. 
 

Dept/Overall Stock Differences 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Stock Maintenance >  Dept/Overall Stock Differences. 

This routine searches for any stock items have a department total which does not match the 
overall total in the system. 

 

Select the date for your report. 

 

If there are any stock items where these totals do not match, a prompt will be displayed and 
VisionVPM can display a list of the stock items where problems exist. 
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These can then be corrected manually through the stock module. 

 
 

Calculate Bar Codes 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Stock Maintenance >  Calculate Bar Codes. 

This is the procedure used for VisionVPM to generate barcodes for stock items.  

 

Click Yes to proceed. 

The following prompt will then be displayed: 

 

Select No if you only require barcodes for items that do not yet have a barcode. 

Select Yes to create barcodes for all stock items. 
 

Mark Formulated Stock Items 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Stock Maintenance >  Mark Formulated Stock Items. 

 

This procedure will mark all formulation components as members of a formulation. 
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Average Cost Differences 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Stock Maintenance >  Average Cost Differences. 

 

This procedure will display stock items where the average cost on the Stock Details window is 
different from the calculated average cost. 

 
 

Delete Update Stock on Hand Journals 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Stock Maintenance >  Delete Update Stock on Hand Journals. 

 

This procedure will delete the stock adjustment transactions in a specified date range. This 
should only be done in conjunction with advice from the Provet IT Service Desk. 

 
 

Packsize Changes 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Stock Maintenance >  Packsize Changes. 

 

This procedure identifies and displays any products where there have been packsize changes. 
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Calculate Stock Codes 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Stock Maintenance >  Calculate Stock Codes. 

 

You can quickly generate new codes for all your stock items using this procedure. The new codes 
will be based on the first four characters at the start of the description and characters at the end.  

This will overwrite all existing codes and is irreversible.  
 

Unique Stock Codes 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Stock Maintenance >  Unique Stock Codes. 

 

This procedure is a check for any stock items with identical stock codes. The routine will identify 
the duplicate codes and add an extra number to the end of each of these codes so they become 
unique. 

 
 

Delete Duplicated Stock Reminders 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Stock Maintenance >  Delete Duplicated Stock Reminders. 

 

Occasionally reminders may be added to a stock item more than once. This routine will search 
for those duplications and remove them. 

Note: This routine will only remove the duplicates when they have the same code and the same 
frequency.  
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Round Stock Prices to 2dp 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Stock Maintenance >  Round Stock Prices to 2dp. 

 

Rounding of prices to three decimal places can cause discrepancies in the totals of different 
reports. If all sale prices are rounded to 2 decimal places, this should eliminate differences in 
reports due to rounding.  
 

Round Sale Prices to nearest 10c 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Stock Maintenance >  Round Sale Prices to nearest 10c. 

 

VisionVPM uses the Swedish rounding system where prices ending in 1 to 4 cents are rounded 
down and prices ending in 5 to 9 cents are rounded up. This routine will apply the rounding to all 
non-formulated stock items.  
 

Stock Control Check 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Stock Maintenance >  Stock Control Check. 

 

This procedure checks for any stock entries that are out of balance. 



'��
�

�

Click Yes to continue, then enter the required date range. 

 

Click OK. 
 

Average Cost - Current Cost Differences 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Stock Maintenance >  Average Cost - Current Cost Differences. 

 

This routine identifies stock items where the average price stored for the item is higher than the 
current cost.  

Click Yes to continue, then Enter the percentage difference. 

 

The report generated can be sent to the print option of your choice. 
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Fix Incorrect Stock Amounts 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Stock Maintenance >  Fix Incorrect Stock Amounts. 

 

Click Yes to correct any stock quantities or values that are incorrectly displayed. 
 

Mark Stock Items as Consumables 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Stock Maintenance >  Mark Stock Items as Consumables. 

This routine will mark the nominated stock records in an analysis group as consumable products. 

It will automatically create a stock adjustment removing the stock onhand amount from the stock 
record.  

�  If the stock on hand is a positive amount, the stock adjustment journal will decrease your 
stock control account by the value of the stock on hand and increase your Cost of Sales 
account by the same amount.  

�  If the stock on hand is a negative amount, the stock adjustment journal will increase your 
stock control account by the value of the stock on hand and decrease your Cost of Sales 
account by the same amount.  

Note: Depending on the size of the stock adjustment, this may cause an increase or decrease in 
your Cost of Sales in the month that you turn stock products into consumables. Therefore, this 
may then result in a higher or lower profit figure for the month. 

If you wish to use your consumables for automatic reordering you will need to stocktake your 
consumables in order to enter the correct stock onhand amounts. 

You can choose to attach a particular purchase or expense general ledger account to each stock 
item. 

You can also choose to allow VisionVPM to: 
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�  calculate the Pack Cost from the last supplier invoice. 

�  apply $1.00 to the Pack Cost, if there are no previous supplier invoices on the stock record. 

The following message will be displayed when you run the procedure: 

 

��  Click Yes to the above message and the following window will be displayed: 

 

��  Click the Selected Analysis Group arrow to select the Analysis Group which contains the 
stock records that you wish to mark as consumables. 

��  Optional items:  

1. Click the Change the purchase group to arrow and double-click to attach a purchase or 
an expense general ledger account. 

2. Select the Calculate the cost from the purchase activity for items without a cost check 
box. 

3. Select the Calculate the cost as $1 if there is no purchase activity  check box. 

If you choose to leave the last two fields blank, the Pack Cost will remain as it was prior to 
running this procedure. 

��  Click OK. 

VisionVPM will: 

�  run through every stock item in the selected analysis group, 

�  mark them as consumables,  

�  remove any stock on hand,   

�  apply any of the optional items you have selected.  

You can display a list of your consumable stock records by going to Main menu > Stock 
module > Reports menu > Stock List > select Consumable > OK. 
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Check Stock Transfer Links 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Stock Maintenance >  Check Stock Transfer Links. 

 

This procedure should only be used in conjunction with advice from the Provet IT Service Desk. 

Supplier Maintenance 

The Supplier Maintenance options assist with the supplier data. These options enable you to 
work with many supplier items at once rather than using the individual supplier detail windows. 
 

Reverse Goods Receipts 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Supplier Maintenance >  Reverse Goods Receipts. 

 

This facility is available for when received items have been loaded through a goods receipt and 
also loaded again from the invoice when it is received. Reversing the goods receipt that is still in 
VisionVPM will remove the stock double-ups that have occurred. 
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Goods Reversal Dates 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Supplier Maintenance >  Goods Reversal Dates. 

 

This procedure enables you to change the date a goods receipt was reversed to match when the 
invoice was loaded into the system to keep your stock levels correct. 
 

Rebuild Supplier Activity 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Supplier Maintenance >  Rebuild Supplier Activity. 

 

This procedure should be used in conjunction with advice from the Provet IT Service Desk. 
 

Change Supplier Account Nos 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Supplier Maintenance >  Change Supplier Account Nos. 

 

This routine allows you to enter or change the bank account numbers of a number of suppliers on 
one window. 

First you are given the option of listing all creditors or only those set up for Direct Credit 
payments 

.  
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Change or enter the required account numbers. 

Click Save. 

 
 

Calculate Stock Supplier 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Supplier Maintenance > Calculate Stock Supplier. 

 

This routine updates the Stock Supplier record with information from supplier invoices for a 
given date range.  
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VisionVPM generally does this automatically, so this routine should be used only in conjunction 
with advice from Provet IT. 
 

Delete Duplicate F_Cr_Entry 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Supplier Maintenance > Delete Duplicate F_Cr_Entry. 

 

This procedure will delete all duplicate supplier transactions. This should be done in conjunction 
with advice from Provet IT. 

 

General Ledger Maintenance 

The General Ledger Maintenance options assist with the General Ledger data. These options 
enable you to work with many GL items at once rather than using the individual GL account 
windows. 
 

Check Bank Reconciliation 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
GL Maintenance > Check Bank Reconciliation. 

 

This report shows the opening and closing balances for a selected sequence of statements. It is 
useful for helping to find where problems with reconciliations started when used in conjunction 
with printed statements. 
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Enter the numbers of the statement range you wish to review.  

Enter the Opening Balance from the first statement of the selected series. 

Click OK. 

A report displaying the statement numbers and closing balances for each statement will be 
generated. 

 

 
 

Update GL Levels 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
GL Maintenance > Update GL Levels. 

 

Click Yes to proceed. 
 

GL List 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
GL Maintenance > GL List.  
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This routine allows you to enter or correct page number and SUbtotal information for your GL 
accounts from a single window. 

 

Click OK to accept the changes. 
 

Bank Rec Problems 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
GL Maintenance > Bank Rec Problems. 

 

Where there is a problem with a bank reconciliation, this routine will help identify entries that 
might have the potential to cause a bank reconciliation problem. 
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Update Bank Rec Link 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
GL Maintenance > Update Bank Rec Link. 

 

This procedure checks the bank rec links to the default bank account. It will update any that are 
missing. This procedure should be run in conjunction with advice from Provet IT. 
 

Write Department Budgets 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
GL Maintenance > Write Dept Budgets. 

 

This routine allows you to add a department to your current budgets. 

Enter the code of the department you wish to add to the budget. 

 

The following prompt will be displayed when the routine has been completed. 
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Transfer Accounts 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
GL Maintenance > Transfer Accounts. 

 

This routine can be used when you want to transfer the entire contents of one GL account to 
another. It is very important that you know what you are doing. 

First you are given the option of automatic transfer and deletion of 'tildered' accounts (accounts 
containing the tilder symbol). This is relevant to terminal server clients only, where each branch 
has its own accounts related to the main ones, for example 351~1, 351~2 for the different till 
accounts or 401~1, 401~2 for the different current accounts. 

 

If you select Yes, this routine will commence and the following prompt will be displayed when 
completed. 
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If you select No to transfer and deletion of the tildered accounts, the following window will be 
displayed. 

 

Optional: Select Delete accounts after transfer if you want the accounts to be deleted. 

Double-click the account the entries will be transferred from on the left then double-click the 
account the entries will be transferred to on the right. A prompt, checking if you wish to proceed 
will be displayed: 

 

Click Yes to transfer the accounts. 

 

Payroll Maintenance 

The Payroll Maintenance options assist with Payroll data. These options enable you to work with 
many items at once rather than using individual payroll windows. 
 

Rebuild Holiday Entitlements 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Payroll Maintenance > Rebuild Holiday Entitlements. 
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This routine will rebuild the holiday entitlements from the information available for each 
individual. 
 

Recalculate Holiday Accrued 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Payroll Maintenance > Recalculate Holiday Accrued. 

 

This routine recalculates holidays accrued based on employees' entitlement dates. 

Click Yes to proceed. 
 

Set 2% Employer Kiwisaver Contribution 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Payroll Maintenance > Set 2% Employer Kiwisaver Contribution. 

 

Click Yes to proceed and all employer contributions currently at 1% will be changed to 2%. 

This routine is used to update the employer percentages in KiwiSaver when required. 
 

Add Salary Sacrifice Item 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Payroll Maintenance > Add Salary Sacrifice Item. 

 

This routine is available to assist with establishment of Salary Sacrifice in relation to KiwiSaver. 
This should be used only in conjunction with advice from Provet IT. 
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A salary sacrifice GL account must first  be entered in the Payroll Company Details window. 

 
 

Custom Routines 

This menu gives access to routines built for clients for individual clinic situations. 

 

Set Up Datafiles 

This menu item gives access to a number of routines that can change many records at once. Care 
must be taken if using any of these routines because they cannot be reversed. 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Setup Datafiles. 

To gain access to this area o f the program, you must call Provet IT for the daily password. 

 

The select New Datafile Routines on the top menu bar to gain access to the available options. 
 

Change Stock Prices 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Setup Datafiles > Enter daily password > New Datafile Routines > Change stock prices. 

This option allows you to change Pack Size, pack cost, Markup or sales price on multiple items 
from a single window. You can choose to view a single sales group or all items. Enter the Code 
of the required sales account or leave blank to select all.  
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On the Stock Code Changes window select one or more fields that you wish to edit: Pack Size, 
Pack Cost, Markup , Sale Price. 

Optional: Select Keep Sale Price the same whenever you do not want the sale price to change 
when adjusting other items. 

 

Note: You will be unable to zero pack costs for any items with previous activity unless Allow 
cost changes for products with activity is selected. 

If you try to zero a pack cost on a product with previous activity, without selecting this option, 
the following prompt will be displayed: 
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If you select Allow cost changes for products with activity the following prompt will be 
displayed:  

 

You will need to contact Provet IT to obtain this password. 

Make your required changes. 

Click Save to proceed. 

 

Click Yes to accept your changes. 
 

Import Client Balances 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Setup Datafiles > Enter daily password > New Datafile Routines > Import Client Balances. 

This routine allows debtor balances to be imported into VisionVPM.  

 
 

Insert Client Aged Balances 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Setup Datafiles > Enter daily password > New Datafile Routines > Insert Client Aged 
Balances. 

 

This procedure is for adding an aged analysis of clients to a new datafile or for adjusting the 
aging of existing clients. 
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Enter the date the analysis will apply. 

 

The following prompt will be displayed. 

 

Select Yes to retain any existing clients balances. 

If you select No, all balances for all clients will be zeroed. 

 

Select the fields you wish to edit: 3 Mth, 2 Mth, 1 Mth or Current . 
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Enter or correct the existing balances. 

If you wish to delete any clients, click Allow Deletes. The following prompt will appear and the 
other buttons will become active. 

 

Once you have entered your information, click Save to save the information and close the 
window. 

Another prompt will ask if you are sure you want to save. Click Yes to confirm. 
 

Mixed Case Names 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Setup Datafiles > Enter daily password > New Datafile Routines > Mixed Case Names. 

 

This routine will change the entries in many of the fields to mixed case - starting with a capital 
letter. 
 

Change Stock Codes 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Setup Datafiles > Enter daily password > New Datafile Routines > Change Stock Codes. 

 

This routine enables you to change multiple stock codes from a single window.  
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Click Edit Codes to allow changes in the New Code column. 

 

Click Close to close the window and accept your changes. 
 

Enter Stock Sales/Purchase Groups 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Setup Datafiles > Enter daily password > New Datafile Routines > Enter Stock 
Sales/Purchase Groups. 

 

Click Yes to Continue. 

This routine allows the sales or purchase groups of multiple products to be changed quickly from 
a single window. 
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In the Stock Group Changes window, select items in the left window by clicking, then double 
click on a Sales Code or purchase code in the windows on the right side to reallocate the items to 
that code. 

 

Each time you double-click on a sales code or purchase code, a prompt will be displayed. 

 

Click Yes to continue. 

If you do not wish to see these prompts, select Don't prompt  at the bottom of the window. 

Note: When you clicking Delete the selected stock item will be removed completely. 
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Change Client Names 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Setup Datafiles > Enter daily password > New Datafile Routines > Change Client Names. 

 

This routine offers a quicker way to check and tidy the name and title fields of your clients, for 
example for mailings. 

Select the check boxes of the fields you wish to change. 

Make the required changes. 

Click Save. 
 

Change Client Case 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Setup Datafiles > Enter daily password > New Datafile Routines > Change Client Case. 

This routine makes sure all the client name and address fields are mixed case and that the City 
and code fields are upper case.  
 

Change Equine Details 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Setup Datafiles > Enter daily password > New Datafile Routines > Change Equine Details. 
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This allows you to change several fields on multiple equine records from a single window. 

You can click on any of the headers to sort by that field. 

Check the box(es) of the fields you wish to edit. 

 

Click Save to close the window and save the changes. 
 

Delete Accounts 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Setup Datafiles > Enter daily password > New Datafile Routines > Delete Accounts. 
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Click Yes to continue. 

 

Highlight the unwanted account and click Delete Accounts to permanently remove that GL 
account. 

The following prompt will be displayed: 

 

Click Yes to proceed. 
 

Add Stock Discounts 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Setup Datafiles > Enter daily password > New Datafile Routines > Add Stock Discounts. 

Multiple stock discounts can be added from a single window. 
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Click Yes to continue. 

 

Data can be sorted by clicking any of the column headers. 

Select Auto tick Prompt to place a tick in the prompt box for all stock items. 

Select Auto tick Incentive to place a tick in the incentive box for all stock items. 

Type a marker into the Set Default Marker field for it to become the default marker. 

Percentage discounts can be quickly viewed and added to or changed. 

Click Save to close the window and save your changes. 
 

Unique Stock Codes 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Setup Datafiles > Enter daily password > New Datafile Routines > Unique Stock Codes. 

This routine checks that every stock item has a unique stock codes and will generate a new code 
for any duplicate items by adding a number to the end of the existing code. 
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Click Yes to continue. 
 

Change Stock Types 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Setup Datafiles > Enter daily password > New Datafile Routines > Change Stock Types. 

This procedure allows you to quickly sort your stock by Type. These types can be viewed on the 
Stock details windows and are utilised in the Vet Stock Type Analysis report available under 
reports in the stock module. 

 

Click Yes to continue. 

 

Select the stock items you wish to change and then double-click on the appropriate stock type. 

Click Close to save your changes and close the window. 
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Attach Reminders 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Setup Datafiles > Enter daily password > New Datafile Routines > Attach Reminders. 

 

This procedure enables you to quickly find and change reminder codes when you need to do a 
rationalisation. 

 
 

Change Animal Breeds 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Setup Datafiles > Enter daily password > New Datafile Routines > Change Animal Breeds. 

This procedure enables you to scan through the breeds in your database and quickly change any 
duplicate or incorrect breeds. 

 



����
�

�

Click Yes to continue. 

 

Select the items on the left so that they are highlighted and then double click on the required 
breed on the right to change the breed. 

Click New Breed to add a new breed to the existing list. 

 

Click OK to save the new breed and return to the Breed Changes window. 

Click Close to close the window and save your changes. 
 

Swap Reminders 

Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance > 
Setup Datafiles > Enter daily password > New Datafile Routines > Swap Reminders. 
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This procedure helps you to quickly change one type of reminder to another. 

 

Select the reminder which you wish to change from on the left and the reminder you wish to 
transfer to on the right and then click Transfer. A prompt will be displayed: 

 

Click Yes to complete the transfer. 
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Procedures 

Departmentalising an Existing Clinic 

There are several steps to departmentalising your clinic. 

Steps 1 to 5 need to be completed before you start using departments. 

For financial reporting it would be advisable to start using departments at the start of a month. 
Therefore, set up (including a physical stock take)needs to be completed at the end of the 
previous month . 

Setting up for Departments 

��  Go to: Main menu > Maintenance module > Maintenance menu > Codes and Descriptions 
> Departments.  

�  Create department codes for your departments. 

��  Go to: Main menu > Maintenance module > Maintenance menu > System Defaults > 
System tab.  

�  Tick Use Analysis by Department. 

��  Go to: Main menu > Maintenance module > Maintenance menu > Computer Defaults. 

�  Type the default department in the Default Dept box.  

�  This needs to be entered on each workstation and would normally be your head 
office/clinic department number (dept 1). 

��  Stock transfer. 

�  All stock will currently be sitting in department 0. 

All stock must be transferred into department 1 or the main clinic department. This is done in 
Main menu > Maintenance module > Maintenance menu > Database Maintenance > General 
Maintenance > Write Non Dept Entries.  

�  This will load all stock into department 1 as well as all other financial transactions, which 
are currently entered as department 0. 

��  A physical stock take will need to be done for the entire clinic (including all vets' cars). 

Entering Stock into the New Departments 

When entering the stock take for the first time via departments: 

1. Go to: Main menu > Stock module > Stock menu > Stock Taking > Stock Taking 
Options. 

2. Select Include Products without Activity  so that all stock items are displayed. 

3. Enter the stock quantities from the physical count for that department.  

OR 
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1. Transfer the stock quantities counted at stock take for the vets' cars, from dept 1 to the 
corresponding vet's dept.  

2. This way the stock take list will show only these items. 

Maintaining Department Stock Levels 

When vets take stock from the clinic, enter stock transfer journals in Main menu > Stock module 
> Stock menu > Stock Transfer. 

These can be done on a daily or weekly basis, depending on volume. 

Default Departments 

When departments are set up, the default department will be displayed on client/supplier 
invoices, General Ledger journals and cashbook deposits/payments. The default department can 
be set up for each individual computer in Main menu > Maintenance module > Maintenance 
menu > Computer Defaults. 
 

To Clear out Old Transactions 

After the End of Year rollover has been done you may wish to clear old transactions from your 
system prior to a certain date to reduce the size of your database. 

This should be performed after hours as it will take some time and would significantly impair the 
performance of  computers accessing VisionVPM (they would be extremely slow). 

To Clear Transactions 

��  Go to: Main menu > Maintenance module > Maintenance menu > Database Maintenance 
> General Maintenance > Clear Old Transactions. 

 

��  Click Yes to continue. 

 



����
�

�

��  Type start date in the From Date box and finish date in the To Date box, then click OK. 

 

��  Click Yes to continue.  

��  The procedure will then delete the data. If there is a lot of data, this will take some time. 
 

Merging Duplicate Clients or Animals 

If you discover that you have created duplicate clients or animals in VisionVPM you can transfer 
the details from one client to another and delete the surplus client or animal. There are several 
different situations that can arise.  

Duplicate client with no animals and different fina ncial activity on each client. 

��  Take a note of the sequential number of the client you want to keep. This is found on the 
client details window, in the box to the right of the Notes and Finance Tab. 

 

��  Go to the Client Details window of the client you don't want to keep. 

��  Click More Commands > Transfer Info . 
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��  Click Yes to continue. 

 

��  If you are not logged on as Admin you will need to enter call Provet IT and ask for the daily 
password.  

��  Enter the sequential number of the client from 1) above. 

 

	�  We recommend that you do not select Delete the current client… once the transfer has 
completed unless you are absolutely certain that everything you need will be transferred. For 
example, client notes are not transferred and some of these may be important to the client 
information. 


�  Click OK. 

 

��  Click Yes to continue. 

 

���  Click OK. 

���  Once you have checked that everything has been transferred correctly, find the client you 
transferred the information from and delete the client: 

�  Click Commands. 

�  Click Delete. 

�  Click Yes to continue. 

Duplicate client with same animals and different fi nancial and/or clinical activity 
on each client. 
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Follow all the steps above.  

You will now be left with one client with duplicate animals. If there are different clinical history 
items for each of these the animals, you will need to transfer the history from one animal to the 
other animal and delete the animal the history was transferred from. 

��  Rename one of the animals and call it, for example, Fluffy1. You will now have a Fluffy and 
a Fluffy1. This will help to distinguish between the two animals. 

If there are reminders on this animal, the following prompt will be displayed.  

 

��  Click Yes to continue.  

��  Go to the History tab for Fluffy1 and select all clinical records by clicking and dragging until 
all lines are highlighted. 

��  Click More Commands. 

��  Click Transfer History. 

 

��  Click Yes to continue. 

 

	�  The search window is then displayed. Use then Animal List window in the usual way to find 
and select the  animal you wish to transfer the history to, for example, Fluffy. 


�  Check that all Fluffy1's records have been transferred to Fluffy. If they have been transferred 
correctly you can delete Fluffy1: 

�  Click on Commands. 

�  Click on Delete Animal. 

�  Click Yes to continue.  

Duplicate client with same animals and same financi al or clinical activity on each 
client.  

Select the activities that are the same and delete them. You will then have duplicate clients with 
the same animals and different financial and clinical activity and can follow the steps listed in 
scenario 2 above. 
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To Check and Standardize Breeds and Species 

Go to: Main menu > Maintenance module > Maintenance menu > Codes and Descriptions > 
Animal Breeds 

 

To check that the species are standard, click species to sort by species. The species entries that do 
not conform will be easy to locate and change. 

The easiest way to check through the species would probably be to sort by species and then 
export to Excel or print.  

Note: that this gives you a new page per species so it may be quite long. Review the list. Decide 
how you you will standardise, then edit details where necessary. 

IMPORTANT. If you decide that you are going to completely delete some Breeds, this will 
delete the breed details in the animal records window of those animals presently assigned with 
that code.  

There are two ways of working with this: 

��  Use the Marketing Schedule to obtain a list of animals presently assigned that Breed code.  
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�  Go to: Main menu > Clients module > Clients menu > Marketing Schedule > Insert > 
Animal  tab. 

�  Click Breed, then double click to select the breed Run the search. 

�  This will give you a list of the animals presently attached to that breed. Once the breed is 
deleted you will need to go back into each of those animals and assign them a new breed. 

��  Use New Datafile Routines 

�  Go to: Main menu > Maintenance module > Maintenance menu > Database 
Maintenance > Setup Datafiles > Enter daily password > New Datafile Routines > 
Change Animal Breeds. 

�  This procedure enables you to scan through the breeds in your database and quickly 
change any duplicate or incorrect breeds. 

�  Click Yes to continue. 

 
�  Click the Breed header on the left to sort by breed then scroll to locate the breed you are 

planning to delete. 

�  Select all the animals with that breed on the left, then double-click on the required breed 
on the right to change the breed. 

Once the animals have been listed or those animals have been allocated a new breed, the 
unwanted breed can be deleted. 
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Utilities 

This part of the program contains functions and procedures to assist with maintaining your 
database and to optimise how VisionVPM runs. 

There are several options available from the menu. Most of these should not be run without prior 
consultation with Provet IT. 

 
 

Database Utilities 

Go to: File menu > Utilities module > Utilities menu > Database Utilities 
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Defragmentation 

It is beneficial to defragment your VisionVPM indexes on a regular basis, for example each 
month. This may help if you notice the program is running slowly.  

Note: It is important not to interrupt this procedure while it is running. 

��  Ensure everyone is out of VisionVPM. 

��  Run a one off backup. 

��  The following should be performed on your SERVER: 

�  Go to: File menu > Utilities module > Utilities menu > Database Utilities. 

�  In the Performance box select Defragment Indexes and keep the percentage at 10%. 

�  Do not make any other selections. 

�  Click OK. 

��  Leave this to run. We estimate it will take 5 – 40 minutes depending on the size and 
fragmentation level. It will take longest the first time it is run.  

��  When it has finished a Results dialogue box will be displayed. Click OK, then Close to close 
out of the Database Utilities window. You are now able to carry on using VisionVPM as 
normal. 

Scanning Data for Faults 

This procedure scans for data faults on your VisionVPM database.  

Note: It is important not to interrupt this procedure while it is running.  

��  Ensure everyone is out of Vision VPM. 

��  Run a one off backup. 

��  The following should be performed on your SERVER: 

�  Go to: File menu > Utilities module > Utilities menu > Database Utilities. 

�  In the Database Integrity box select Scan for Data Faults. 

�  Leave the selection as Repair Fast No Data Loss. 

�  Do not select any other options. 

�  Click OK. 

��  Leave this to run. We estimate it will take 2 – 20 minutes depending on the database size and 
speed of your server.  

��  When it has finished a Database Error Details window will be displayed. If there are any 
allocation errors, a report should be printed off at the bottom of the window and faxed to 
VisionVPM. 
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Reindexing 

Database tables have indexes to help speed up data access. If there has been database corruption, 
it is advisable to reindex these tables. To do this, click Reindex Tables in the Database 
Integrity  box. 

Shrink Database File 

Shrinking a database file is not recommended. The database performs better when expanded. 
 

Database Settings 

Go to: File menu > Utilities module > Utilities menu > Database Utilities. 

The Database Settings window is where you can customise the database to best suit your 
hardware and operating environment. The settings here should allow you to get the best 
performance from your database.  

Several options for database settings are offered on this window. A Use Recommended button, 
offered in each section, will automatically select the settings recommended by VisionVPM.  

There are 4 sections on this window:  

The first section is a display of basic database properties such as its name, size and the specific 
version of SQL Server that you are using. 

 

 



��#�
�

�

Database Properties 

The second section groups together database settings that tell your database how to behave.  

 

�  Auto update statistics: Checked, this will enable the database to remove out-of-date 
statistics that it may have collected. This will optimise its queries. It is recommended that this 
should be selected. 

�  Auto create statistics: Checked, this will enable the database to automatically create missing 
optimisation statistics. Missing statistics needed by a query for optimisation are automatically 
built during optimisation. It is recommended that this should be selected. 

�  Full Mode Recovery (enables transaction logging): Unchecked, this will disable the 
creation of transaction logging. The transaction log requires additional space and 
maintenance. The transaction log file is great for large sites that demand a high level database 
recovery model as it allows for data recovery to a specific date and time.  

To achieve this, the database must also be backed up in a very specific way and restoring to a 
point in time must also follow strict guidelines.  

Typically this adds a complexity that is best left to large sites that employ database 
administrators. It is recommended that this should not be selected. 

�  Auto Shrink: Checked, this will allow the database to recover unused space. While this 
sounds like a good idea, the database works best when it has free space within its data file. It 
is recommended that this should not be selected. 

�  Auto close:  Checked, this tells the SQL server to shut down and free resources for the 
database after the last user exits. When Auto close has been enabled you may experience 
slight delays as the database re-opens and allocates resources for itself. If you rarely use the 
database then you may decide to enable this option, but having the database on and ready will 
give you a much snappier performance. It is recommended that this should not be selected. 

�  Use Recommended: This will enable and disable the settings to VisionVPM 
recommendations. 

Database Size  

The third section is for increasing the amount of physical hard drive space the database will use. 
The database will perform better when it has plenty of free space to write to. If the database is 
low on space it will attempt to grow. This may slow down performance or result in a fragmented 
database file which will also slow performance. We recommend that the database is set to a 
reasonably large size. The maximum size of a database varies between SQL Server versions.  
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Typically for the following versions these size restrictions apply: 

MSDE 2000: max database size is 2GB (2048MB) 

SQL Express 2005: max database size is 4GB (4096MB) 

If you have enough free hard drive space then we recommend you set the database to its 
maximum size but not exceeding 4GB unless you are a very large site. If you are using a version 
with the size restrictions then you may use the recommended button to make the adjustment. 

Server Memory  

The fourth section is for setting the amount of physical memory that SQL server will use.  

 

Min Memory allocated to SQL (MB) is the minimum amount of RAM that SQL Server will 
use. When SQL server starts up, it will secure this amount of RAM.  

Max Memory allocated to SQL (MB) is the upper limit of RAM that SQL Server will use.  

If SQL Server is low in RAM it will attempt to acquire more RAM but will not exceed the Max 
limit. 

There are generally 2 scenarios for adjusting the min and max limits:   

Dedicated SQL Server computer 
�  A computer that is only used to run SQL Server.  

�  Min memory is set to about 1/3 of the total physical RAM.  

�  Max memory is set the total amount of physical RAM available.  

�  This allows SQL Server to automatically use as much RAM as it needs. 

SQL Server on a computer with other applications 
�  Min and Max memory are set to the same amount.  

�  This is done so that SQL Server is guaranteed the RAM before another application takes it 
for its own needs. Guidelines for the min max values are calculated as follows: 

�  < 3GB of physical RAM.       Min max: 1/3 of the physical RAM 

�  3GB-4GB of physical RAM.   Min max:  1/4 of the physical RAM 

�  > 4GB of physical RAM.        Min max:  1GB. 

�  You can use either of the Use Recommended buttons to adjust the min max memory 
values. 
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Backups 

SQL 2005 Express Manager is provided with your VisionVPM Software. This tool can be used 
to run one-off or scheduled backups of your database. You should use this tool in conjunction 
with your operating systems backup program and removable media to create a high availability 
backup procedure. 

Recommendations for backing up data 

By creating three backup jobs and having a local copy and an off-site copy you will have more 
options when and if you are required to restore the database. Create three scheduled backup jobs 
for: 

�  A daily backup 

�  A weekly backup 

�  A monthly backup 

Each of these backups should have its own directory on the server's hard drive. For example, on 
the server's hard drive create a folder called c:\Backups and in this create three folders called 
Daily, Weekly and Monthly . Use the backup tool to schedule the three backup jobs to be backed 
up into the appropriate directory. 

Note: You do not need to shut down any VisionVPM programs in order to backup. 

Always take a backup home or off-site. Use the operating system's backup program to create a 
backup routine that will backup the contents of the dbBackup folder onto your removable backup 
media. Removable backup media could be a re-writable CD, Tape, Memory stick, etc. This way 
you will protect your valuable data from hard drive failure, fire, theft, etc.  

Test backed up data to ensure that it will restore and that it is current.  

Before you begin 

�  SQL2005 Express Manager must be run from the server that is running SQL2005 Express. 

�  Data can only be backed up to computers with SQL2005 Express Manager and SQL2005 
Express installed and their associated removable media (for example, memory sticks and re-
writable CDs). 

�  For a backup procedure to run the following requirements must be met: 

�  The server must be on at the time the backup is scheduled to run. For example, if you 
scheduled a backup job for 1:00 AM and you turn your computer off between 5:00pm and 
8:00AM, the backup will not work.  

�  SQL Server 2005 must be running when the backup is scheduled to run. 

To Perform a One-Off Backup  

To perform a one off backup of your VisionVPM SQL database you need to. 

��  Run SQL2005 Express Manager and select the Backup tab. 
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��  Select the database to backup. 

Enter the location to back up to or use the Browse button to find the location for the backup. 

��  Click Backup Now. 

��  The selected database will be backed up immediately. 

To Perform an Automated Backup 

To schedule an automated backup you need to: 

��  Setup the backup in the SQL Express Manager 

��  Create a new Scheduled Task using the Windows task scheduler 

To setup the backup in SQL Express Manager: 

��  Go to: Start menu > Programs > Vision > SQL-Tools > SQL 2005 Express Manager. 

��  From the SQL 2005 Express Manager window, click the Backup tab. 

��  In the Database box, select the database you want to backup. 

��  Browse for the location to backup to. 

��  Click Save as Script to save the backup job as a batch file and select a location to save the 
batch file to. This batch file will be used by the Windows Scheduled Tasks program to 
perform the backups. 

��  Click Close. 

To create a new scheduled task 

��  Go to: Start menu > Program Files > Accessories > System Tools > Scheduled Tasks > 
Add Scheduled Task. 

��  From the Scheduled Task Wizard window, click Next then click Browse and locate the 
batch file you previously saved.  

��  Assign the task a recognisable name and set the frequency for the task to run, then click Next. 

��  Set a time, frequency, and date that you wish the task to start, then click Next. 

��  Enter the user name and password, confirm the password, and then click Next. 

�  The user setting up this task must have Logon as a service selected as part of their user 
rights. 

��  Click Finish. 
 

Updating VisionVPM 

When VisionVPM updates are available, VisionVPM will notify you by email. The email will 
contain a link to the ftp site from where the update is available, instructions on the updating 
process and a copy of the relevant release notes. 
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Installing an update is a technical procedure and if you are not comfortable with basci windows 
functions such as copying and pasting files or locating the server across the netword, you should 
ask an IT technician to perform this procedure. 

Before you begin 

Before you install the update, you must do the following: 

��  Backup your VisionVPM database. 

��  Close VisionVPM on the server and on all workstations. 

To Download the Update 

��  Double-click on the link in the update email. 

��  Click Save to save the file to your hard drive. 

��  From the Save As window, locate the Omnis7 folder (or the folder that VisionVPM has been 
installed in) on your server. 

Ensure the file name is VPMUpdate.exe. 

��  Click Save. 

The file VPMUpdate.exe has been saved in the Omnis7 folder on the server and you are ready to 
install the VisionVPM update. 

To Install the VisionVPM Update on your Server 

��  Check that VisionVPM has been closed down on your server. 

��  On the server, find and open the Omnis7 folder, and then double-click VPMUpdate.exe to 
begin the installation. If VisionVPM has been installed in a different folder you will need to 
locate and open that folder. 

��  In the Setup - VisionVPM Update window, click Next. 

��  In the Password box, type 0077. Click Next. 

��  The destination directory displays c:\Omnis7 or the folder where VisionVPM is installed. 

��  Click OK then click Finish. 

The server will be updated to the new version of VisionVPM. 

To Update the Workstations 

��  Check that VisionVPM has been closed on the workstation you are updating. 

��  Double-click Network Neighbourhood and locate the server. 

�  If you are running Windows 2000 you should double-click My Network Places. 

��  Find and open the Omnis7 folder on the server and then double-click VPMUpdate.exe to 
begin the installation. If VisionVPM has been installed in a different folder you will need to 
locate and open that folder. 
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��  In the Setup - VisionVPM Update window, click Next. 

��  In the Password box, type 0077. Click Next. 

��  The destination directory displays c:\Omnis7 or the folder where VisionVPM is installed. 

	�  Click OK then click Finish. 

The workstation will be updated to the new version of VisionVPM. This procedure needs to be 
repeated on each workstation. 

Note: If the VPMUpdate.exe file is copied to a memory stick, this can be carried between 
computers for installation of the update rather than having to locate the server from each 
workstation. 

Using the VisionVPM Update 

�  Do not open VisionVPM until the update has been installed on the server and all 
workstations. 

�  Open VisionVPM on the server first and answer Yes to the two pop-up messages that are 
displayed.  

�  The server and the workstations must all run the same version of VisionVPM. You can check 
the VisionVPM version number by reading the Build No on the VisionVPM splash screen 
when the program opens or from Help menu > About VisionVPM. 

 
 

Accessing VisionVPM Support 

VisionVPM is serviced by the Provet IT Service Desk which has a number of software support 
and technical support staff to assist with your questions. 

User Manuals and online help are available from the VisionVPM website:  www.visionvpm.com 
- click the VisionVPM Support button on the left side of the website to access information and 
options. The on-line help can be accessed directly from VisionVPM on any computer with 
internet access by going to Help menu > VisionVPM Help (F1). The VisionVPM website can 
also be accessed from the Help menu > VisionVPM on the Web > VisionVPM Web Site. 

Premium support clients can access VisionVPM support on toll free numbers: 0800 847 876 for 
New Zealand clients and 1800 150 264 for Australian clients. 

The Provet IT Service Desk can also be contacted  

�  by email:  Support@visionvpm.com  

�  by fax on (NZ) 07 927 5740 (Aus) 02 9894 5298 

Sometimes your questions are most easily answered if we can see what you are doing and what is 
happening as you are doing it. 

Provet IT (with your permission) can access your computer remotely from our office and view 
what you are seeing on your computer screen. 



�4��
�

�

Note: This can only be done if you log on to the internet AND follow the instructions given by 
Provet IT. Provet IT cannot access your computer system without your knowledge and 
cooperation. 

To Permit Remote Access from Provet IT 

For Provet IT to provide remote access support, the computer you are using must have access to a 
broadband internet connection. 

Before trying to access the VisionVPM remote support website, first contact Provet IT by phone 
to confirm that remote access is needed and that there is an operator available.  

Once it is agreed that Provet IT will access your computer remotely, you can access the remote 
support from either  

�  The Help menu  

�  Go to: Help menu > VisionVPM Remote Support 

  
�  The VisionVPM website: 

�  Go to www.visionvpm.com 

�  Click on the large question mark at the bottom right of the window. 



�4��
�

�

Both options will take you to the HelpBeam website: 

 

Provet IT will then supply you with a 12 digit number that you will enter. Please note that these 
numbers change on a regular basis. 

Enter the number you are given and click Get Help. 
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Click on Click Here to Download the HelpBeam Application. 

 

Click Run to run the application. 

 

Click Run to continue. 

 

Click Yes to allow the operator to have remote access to your computer. 
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A disconnect prompt will be displayed in the centre of your screen. Minimise this prompt. If any 
any time you wish to or need to disconnect, maximise the prompt again and click disconnect. 

The connection can also be terminated by VisionVPM. This will happen at the end of the support 
call or when the issue is resolved. 

Very occasionally, because of firewalls, virus protection or the way clinic computers are setup, 
VisionVPM will be unable to access your computers in the above way. There are alternative 
access solutions available for most, but not all scenarios.  
 

Database Copies 

Sometimes if a computer cannot be accessed remotely or a problem is particularly involved or 
may require considerable investigation or testing, VisionVPM may ask for a copy of your 
database. These copies may be sent via CD (though some are now getting too large for a CD) or 
can be uploaded to VisionVPM's ftp server. Your data will only be accessed by VisionVPM staff 
and only for providing solutions to the questions you have asked. 

Run a one-off back up and copy it to a CD or upload it to the ftp server. 

Uploading to the ftp server 

(ftp means file transfer protocol) 

��  You will need to compress the datafile file for upload to reduce the time and cost of 
transferring the file to the ftp site. 

Please use either WinZip or WinRAR to compress the datafile. These programs can be 
downloaded for evaluation or use if you have not already installed them from: 

�  www.winzip.com 

�  www.rarlab.com 

You will now have a *.zip or *.rar file. Right click and take a copy of this file. 

��  Transfer the compressed datafile to our FTP site. 

Go to: VisionVPM > Help menu > VisionVPM on the Web > Open ftp Uploads Folder 
You are now accessing a folder on our ftp site across the Internet.  

Right click and paste (or Edit menu and paste function) the compressed file into a new folder 
created for your clinic. 

This will start copying the file. The time taken will depend on the file size and your internet 
connection speed. 

��  Transfer Notification. 

When this is complete, please send an email confirming the upload has been completed to 
support@visionvpm.com with the subject title "Upload Complete" 
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