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Changes to the Client Module 

This section describes the changes that have been made to the Clients module. 
 

Changes to displaying of drugs/products on the clin ical record 

Go to: Clients menu > Animal Details > select animal > Record. 

Previously, if you had selected to display the Drugs tab on the Clinical Record, and you 
bypassed the Drugs tab and entered stock items on the invoice, VisionVPM displayed all stock 
items in the following areas of the Clinical Record: 

��  Drugs/Products Added area: 

 

 

��  Drugs tab: 

 

The above functionality did not suit all clients, therefore, a change has been made in VisionVPM.  

Now, if you bypass the Drugs tabs, only stock items with a drug label entered on an invoice will 
be displayed on the Clinical Record. 

All stock items entered through the Drugs tab will be displayed on the Clinical Record as in the 
previous version. 

If you have selected to not display the Drugs tab, all stock items will be displayed on the Clinical 
Record, as in the previous version. 
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Ability to search by Animal Seq Number 

Go to: Clients menu > Animal Details. 

You now have the ability search for animals by their sequence number. An Animal Seq No. 
option has been added to the Search By list, as shown below: 

 

You can use this number, for example, for radiology. 
 

Additional Merge fields for Vacc Adhocs 

To edit vaccination reminder adhocs, go to: File menu > Adhoc Reports > Reports > Open > 
select adhoc.  

To run vaccination reminder adhocs, go to: Main menu > Client module > Client menu > 
Reminder Schedule > make selections > Run > Adhoc. 

The Vacc Reminder Adhocs now have the following options: 

�  You can now include the Reminder Text in adhocs. 
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�  This field is called [F_Vet_Remind.REM_BODY]. 

 

�  All patient adhocs have the option of adding the field [ANIMALPHOTO] to display the 
animal's photo. Please note that the size of the photo cannot be changed from the thumb nail 
size (max of 2.5 cm for length and height). 
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Changes to the Supplier Module 

This section describes the changes that have been made to the Suppliers module. 
 

Ability to select an edited line position 

Go to: 

�  Suppliers menu > Supplier Invoice > select invoice > Edit  

OR 

�  Suppliers menu > Goods Receipts > selected goods receipt > Edit . 

Currently, when you edit a line in either a supplier invoice or a goods receipt, VisionVPM will 
drop the line back to its original position in the invoice. 

A change has been made to allow you to specify whether the edited line drops to the bottom of 
the invoice or back to the place it was originally. 

To be able to drop the line to the bottom of the invoice you must select one of the following 
options by going to: Main menu > Maintenance module > Maintenance menu > System 
Defaults > Financial tab > Supplier Financial area. 

 

On applying this update, the default will be set to None. That is, VisionVPM will drop the edited 
line back to its original position. 
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Changes to the Payroll Module 

This section describes the changes that have been made to the Payroll module. 
 

Multiplier of 1.5 for Relevant Daily pay 

Go to: Main menu > Payroll module > Payroll menu > Allowances and Deductions. 

A multiplier field has been added to the popup windows displayed when Prompt for Relevant 
Pay or Prompt for Average Earnings are selected. 

This allows a multiplier to be used on allowances such as Public Holidays. This multiplier will 
come through from the Allowance itself. The selected pay rate will be multiplied by the 
multiplier. 

The multiplier cannot be zero. 

The multiplier is entered in the Allowances/Deductions window: 

 

When loading the pay run, go to Main menu > Payroll module > Payroll menu > Pay Run > 
select employee > edit transactions. 

When the appropriate allowance, for example, Public Holiday, is selected and the Qty is entered 
a pop up window will be displayed. 
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When Prompt for Relevant Pay has been selected, the following window, now with a multiplier 
field, will be displayed: 

 

The Allowance Multiplier  value of 1.5 has been brought through from the Public Holiday 
allowance example. 

OR 

When Prompt for Average Earnings has been selected in the Allowance window, the following 
prompt, now with a multiplier field, will be displayed: 

 

The Allowance Multiplier  value of 1.00 has been brought through from a Holiday Pay 
Allowance. 
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Changes to the Maintenance Module 

This section describes the changes that have been made to the Maintenance module. 
 

Ability to select an edited line position 

Go to: Main menu > Maintenance module > Maintenance menu > System Defaults > 
Financial tab > Supplier Financial area. 

New options have been added to VisionVPM to allow you to specify whether an edited line drops 
to the bottom of a supplier invoice and goods receipt or back to the place it was originally. 

Currently, when you edit a line in either a supplier invoice or a goods receipt, VisionVPM will 
drop the line back to its original position in the invoice. 

To be able to drop the line to the bottom of the invoice you must select either: 

�  Goods Receipt - will only apply to goods receipts. 

�  Invoice - will only apply to supplier invoices. 

�  GR and Invoice - will apply to both goods receipts and supplier invoices. 

 

On applying this update, the default will be set to None. That is, VisionVPM will drop the edited 
line back to its original position. 
 

Changes to Autobanking 

Go to: Maintenance menu > Codes and Descriptions > Auto Banking Setup. 

The following changes have been made to the Bank Setup window. Please note, these changes 
only affect New Zealand databases. 

��  The TSB bank format has been updated to meet the requirements of the TSB bank. 

��  Dashes have been included in the Your Bank Account Number field to indicate the required 
account number format. For example, TSB require the bank account number to be in the 
following format: 6 - 7 - 3. 
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Resolved Issues 

The following issues have been resolved in this build: 
 

General 

SQL Locks not clearing 

VisionVPM, previously, was not clearing all SQL locks which caused issues when multiple users 
attempted to access the same records. 

Extra checks have now been put in place so when VisionVPM starts up, all SQL locks for a 
user's serial number will be removed as well as any remaining locks for the previous day and 
beyond. 
 

Inability to log into VisionVPM 

Go to: File menu > User Logon. 

Previously, some User codes and Passwords were not recognised by VisionVPM and therefore 
you were unable to log into VisionVPM. This was due to  encryption problems with User codes 
and Passwords. 

This issue has been corrected in this version. 
 

Discount amount incorrect for formulation Stock Pri cing window 

Go to: Main menu > Stock Pricing > enter formulation. 

Previously, VisionVPM displayed the incorrect discount amount on the Stock Pricing window 
when you had selected a stock item marked as a formulation. 
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Now, the correct price is displayed, as shown below: 
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Contact Method removed 

Go to: Quick Access menu > VPM Navigator > select a reminder option. 

Previously, VisionVPM removed the Contact Method from clients when you had selected 
reminders from the Navigator pane. 

 

This has been corrected in this version and now VisionVPM correctly displays clients' Contact 
Method. 

 
 

Clients Module 

Multiple invoices not transferring correctly 

Go to: Clients menu > Client Details > select client > Activity > select invoices > Transfer. 

In the previous version, VisionVPM only transferred the first invoice in the following 
circumstances: 

��  You had selected multiple invoices. 

��  You were transferring the invoices to a client marked as a Syndicate. 

Now, VisionVPM correctly transfers all selected invoices. 
 

Adhoc fields printing in stock letter 

Go to: Clients menu > Animal Details > select animal > Invoice. 

Previously, VisionVPM did not calculate all adhoc fields names in a stock letter when you had 
selected to use an adhoc file as a stock letter. In the example below, the patient's Age, Last 
Vaccination Date and the Vets Name have not printed. 



00�
#��

�

 

 

Now, VisionVPM will display all adhoc fields correctly in a stock letter, as shown below: 

 
 

VisionVPM not displaying up to date reminder inform ation 

Go to: Clients menu > Animal Details > select animal > Record > enter details > Invoice > 
Save > Animal > Reports. 

In the previous version, VisionVPM did not display reminders created today on reports printed 
from the Reports tab of the Animal Details window. 

Now, VisionVPM correctly displays all reminders on reports. 
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VisionVPM not scrolling through Clinical Descriptio n templates 

Go to: Clients menu > Animal Details > select animal > Record > Desc. List > select template. 

Previously, when you had selected a template containing result fields () and the template was 
longer than the screen, when you tabbed through each of the result fields, VisionVPM did not 
move the template up, therefore, you could not see the remainder of the wording. 

 

Now, VisionVPM will move the template up so you have the ability to view the rest of the 
template. 

 

Please note, if there is a line on the edge of the window, VisionVPM will not move the template 
up, however, when you start typing in a result field () the template will be moved up and you will 
be able to see what you are entering. 
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Duplicate animal names on list when batch invoicing  

Go to : Clients menu > Batch Invoice > Insert > Animal Code > enter a letter > CTRL+Q  > 
scroll down list using mouse wheel. 

Previously, when the number of animals displayed exceeded one screen, the animal names 
showed duplicates with the same code. Clicking on any of the lines would make that line 
redisplay the correct animal. 

Now, VisionVPM will display the list of animals without duplicates. 
 

Current and Total amounts displayed incorrectly in Batch Receipting 

Go to: Clients menu > Batch Receipting > enter dates > Yes to displayed client's aged balances. 

Previously, VisionVPM incorrectly displayed the Current and Total amounts on the Batch 
Receipting window. This occurred when you had selected to display the Aged Balances for 
clients. 

Please note, the Current Bal. Due field has been renamed to Balance Due. 

The Balance Due is the total amount a client owes. 

In the example below, the client has a total outstanding balance today of $224.00, with $129.20 
due in the month of March. 

Screen shot in previous version: 

 

Now, VisionVPM correctly displays the client's aged balances, as shown below: 
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Animal name not displayed on invoice/statement 

Go to: Clients module > Reports menu > Invoice/Statement Run. 

Previously, VisionVPM did not display the total amount for an animal's invoices on an 
invoice/statement report. This only occurred in the following circumstances: 

��  You had transferred an invoice to a client marked as a Syndicate. 

��  You printed an invoice/statement report for one of the Syndicate members. 
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This issue has been corrected in this version and, now, VisionVPM correctly displays the total 
amount for an animal's invoices on an invoice/statement report. 

 
 

Overdue amount incorrect invoice reversal 

Go to: Clients module > Reports menu > Check Expired Discounts. 

In the previous version, VisionVPM included delayed charge invoices in the Overdue amount, 
which was incorrect. The Overdue amount should not contain delayed charge invoices until the 
month they are due. 
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In the above example, delayed charges for this client amount to $3859.80, therefore, only 
$1988.00 should be displayed in the Overdue column. 
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This issue has been corrected, and now the Overdue amount is displayed correctly, as shown 
below: 

 
 

Incorrect option prompt when exporting client balan ces 

Go to: Clients module > Reports menu > Export Balances > Print . 

Previously, VisionVPM prompted you to export the file when you had selected to print the 
report. 

This issue has been resolved in this version. 
 

General Ledger Module 

Account Activity report displaying opening balance as zero for Profit and Loss 
Accounts 

Go to: General Ledger module > Reports menu > Account Activity.  

In the previous version, VisionVPM displayed the opening balances of Profit and Loss accounts 
on the Account Activity Report as zero.  The opening balance should have been displayed as 
the closing balance for the previous period so that the account activity equals the amounts on the 
Balance Sheet.   

The opening balance for Profit and Loss accounts is now calculated from the current financial 
year entered in the Date Selection window. 
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Balance sheet accounts are still calculated from the Year Begins date displayed in Company 
Information . 
 

Incorrect general ledger account type displayed 

Go to: General Ledger module > Reports menu > Monthly Profit and Loss. 

Previously, VisionVPM displayed the incorrect general ledger account type on the Monthly 
Profit and Loss report, in the following circumstances: 

��  You had selected the Use subtotal header accounts check box. 

��  You had selected the Send to Excel check box. 

��  The accounts with the incorrect account type had no activity or balance but needed to be 
added to the list as they had other accounts subtotalling to them. 

 

This issue has been corrected, and now VisionVPM displays the correct account type, as shown 
below: 

 
 

Supplier Module 

Supplier invoice loses supplier details when editin g a stock item 

Go to: Suppliers module > Suppliers menu > Supplier Invoice > Insert > enter supplier 
invoice header details. 

VisionVPM incorrectly removed the supplier invoice header details when you took the following 
steps: 

��  From the Supplier Invoice window, enter a stock item. 

��  Partially enter another stock code or description, and click the Code or Description arrow. 

��  Highlight the required stock item, and click Edit . 
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��  From the Stock Details window, click Activity . 

��  Click Close on the Activity window. 

��  Click Close on the Stock Details window,  

	�  From the Stock List window, select the required stock item. 

 

Now, VisionVPM keeps all supplier invoice header details when editing a stock item. 
 

VisionVPM removed the supplier invoice date 

Go to: Suppliers menu > Supplier Invoice > Insert. 

Previously, VisionVPM removed the invoice date when you took the following steps: 

��  You had not selected to use the Delayed Charge function in VisionVPM. 

��  You entered a stock code and clicked the Stock Code arrow. 

��  You double-clicked the required stock item. 
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Now, VisionVPM correctly retains the invoice date. 
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Stock Code not displayed 

Go to: 

�  Suppliers menu > Supplier Invoice > Insert. 

OR 

�  Suppliers menu > Provet Options > Open Pending Invoice List > select an invoice. 

VisionVPM did not display the Stock Code in a supplier invoice when you took the following 
steps: 

��  You either double-clicked an existing stock item line or tabbed through to the Description 
field. 

��  Clicked the Description arrow. 

��  Located and double-clicked the required stock item. 
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Now, when you find a stock item via the Description arrow, VisionVPM will correctly display 
the Stock Code. 

 
 

Ability to save a pending invoice with no date 

Go to: Suppliers menu > Provet Options > Open Pending Invoice List. 

In the previous version, VisionVPM allowed you to save a pending invoice with no date in the 
following circumstances: 

��  You had changed suppliers and, 

��  the selected supplier was not the nominated Provet supplier. 

Now, when you attempt to save a pending invoice in the above circumstances, VisionVPM will 
display the following message: 

 

You will need to click OK and then enter the invoice date. 
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Supplier opening balances missing on statements 

Go to:  

�  Suppliers module > Reports menu > Print statements > enter date > Ok. 

OR 

�  Suppliers module > Suppliers menu > Supplier Details > select supplier > Statement > 
enter date > Ok. 

In the previous version, VisionVPM did not display the Supplier's Balance Forward amount on 
the Supplier statement.  

 

Now, VisionVPM correctly displays the Balance Forward amount, as shown below: 
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Stock Module 

Negative values in formulations not updating 

Go to: Stock module > Stock menu > Stock Details > select stock item > Edit price details > 
Save. 

When you clicked Yes to the message below, previously, VisionVPM only updated formulation 
components that had a value greater than zero. 

  

 If a component of a formulation had a zero or negative total, VisionVPM would not update that 
component in the formulation. 

VisionVPM will now update both positive and negative formulation components.  Zero value 
components (like formulation headers) will not be updated. 

When VisionVPM updates formulations it will update the price to the current sales price * qty 
sold + dispense fee. 
 

Duplicated stock items in Formulation window 

Go to: Stock module > Stock menu > Stock Details > select formulation > Formula. 

VisionVPM, previously, displayed duplicate stock items in the Formulation window. This 
occurred when you took the following steps: 

��  In the Stock Formulation window, double-click a component stock item. 

��  Press ENTER to drop the stock item down again.  

��  Click the Code or Description arrow. 

��  Click Close on the Stock List window. 

�  The previous stock item that you edited is positioned in the editing line.  

��  Press ENTER to drop the line down. 

This issue has been corrected in this version. 
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Reorder Qty rounding part packs to zero 

Go to: Stock module > Stock menu > Stock Ordering > Stock Reorder. 

Previously, when the Round part-packs to a whole pack check box was selected in the Stock 
Reorder Options window, VisionVPM rounded anything less than half a pack to zero. 

 

Now, where a quantity to be ordered is less than 1 pack size, and the Round part-packs to a 
whole pack check box is selected , VisionVPM will round the quantity to be order to 1 pack size. 
 

Boarding Scheduler 

Boarding Schedule overlapping 

Go to: Main menu > Boarding Scheduler. 

Previously, VisionVPM overwrote boarding schedule appointments when a selected suite was 
unavailable for the specified period of time. 

Now, VisionVPM will correctly allocate available suites. 
 

Ability to select incorrect suite number 

Go to: Main menu > Boarding Scheduler. 

VisionVPM was incorrectly creating another boarding suite in the following circumstances: 

��  Edit an existing booking of a suite number that does not exist for another suite name. 

��  Change the suite name without changing the suite number. 
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For example, if you had 3 Dog suites and 2 Cat suites and a booking had been entered in Dog 
suite 3, when you edited the booking and changed the suite name to Cat suite and saved, 
VisionVPM was creating a 3rd Cat suite. 

Now, when you process the above steps, VisionVPM will display the following message: 

 

You must then click OK and select a valid suite number to continue.  


